Cubase 13 - External MIDI Instruments

I’m now 24 hours into my upgrade to C13 Pro from C12 and I seem to have spent more time dealing with new bugs than working with it.

I’ve had a few sudden freezes and crashes, which don’t seem to be attributable to anything specific. My C12 was pretty stable. I’ll create new topics as patterns emerge.

One apparent bug that took up most of yesterday evening to fathom is with External MIDI Instruments. I found that some of them were no longer listed by the Track Inspector under Steinberg>External Plug-ins.

In the External Instruments tab of Audio Connections, there was a red warning icon in the Bus Name column because it wasn’t connected.
I tried to select the MIDI Device but the list didn’t include the device it should be connected to.

In MIDI Device Manager, all the external devices were showing there but at least 2 of them were missing from the available devices when I went into External Instruments.

After a lot of head-scratching and removal and reinstallation of the MIDI devices, I ended up manually renaming the devices in the definition TXT files, then reinstalling them again. This worked and they were once again listed in the MIDI Devices list of External Instruments.

My conclusion is that somewhere in Cubase 13’s configuration the device definitions are still there and associated with an External Instrument too but both have got hidden. This is backed up by seeing that the External Instrument insists on putting a “2” on the end of the name I give it. (eg I had it named “XV-5050” previously. If I try to name it that now, Cubase changes it to “XV-5050 2”. I’ve no idea where those hidden devices have gone or why but I’ve got a workable solution now.

I’ve discovered where to find those external instruments that have been hidden for some reason.

If you go to the VST Plug-in Manager and drill down into the Steinberg folder, there is a Missing Plug-ins subfolder.
Here I found some of the external instruments that I created in C12.

Unfortunately, there seems to be no way to delete just these ones. I could only use the arrow menu at the top-right to “Remove Unavailable Plug-ins for All Collections”

Having resolved this, I was able to go back into the External Instruments tab of Audio Connections and rename them as I’d originally had them


I hope this helps others.