Cubase 13 freezes when opening Analog Obssession plugins

I recently moved to a new PC with Windows 11. and updated from Cubase PRO 11 to Cubase PRO 13.0.30
When I try to add or open a plugin from Analog Obsession (FETish, BUSTERse , SSQ, ATONE, …), Cubase freezes.
Playing continues in the background but Cubase remains stuck for ever.
These plugins worked for me in Cubase 11 PRO older Windows PC, and I know they also work on Mac with Cubase PRO 13.0.30.

Cubase 13 PRO 13.0.30
AMD Ryzen 7 7700
Windows 11 PRO 22H2

@hagaic,

I’m using Cubase 13.0.30 (x64) build 226, March 13 2024 and I’m using the latest version of Windows 11 Home edition, Version 23H2. I also use a few plugins from Analog Obsession and everything works perfectly. I always have Britpressor in the inserts of my Mix Bus. I have already made a few mixes using a few of these plugins and have never encountered any problems.

Try to only use stock Cubase plugins and those from Analog Obsession. Removed all other plugins, the problem could be caused by another third party plugin.

Good luck!

Problem solved.
I installed the AMD CPU driver and it works.
I guess the problem was with AMD integrated graphics support for OpenGL, which is used by Analog Obsession.

1 Like