Cubase 13 Inserts on mono audio track not applied

Lately I have been rehearsing my band using headphones. 2 guitars, bass, e-drums. Live we use amps and acoustic drums. As it’s being done using control room in Cubase I use amp sims on inserts for guitars and bass for a bit more realism and have 3 more tracks just for the clean signals for future reamping if we get something worth keeping.

When I played back the recordings the inserts were still active so I bypassed them and was left with the clean signal. Just to be sure I recorded on the guitar track again using a way OTT delay using Echoboy on the insert and sure enough when I bypassed the insert on playback it was just the clean signal.

Now as I record a separate track so I can have the clean signal as well as the track with the ampsim on I can see that using an insert that isn’t printed on record might be a good idea as you would still have the option of keeping the same plugin or trying a different one later. So the question is, is this not applying the inserts on record a preference or a bug?

If you want to record the signal processed by plugins, put them into the inserts of the input channels. not regular tracks.