Cubase 13 - Midi sends not working as expected?

I have a midi track with a custom drum map that I’m trying to route to 2 instances of Superior Drummer 3. I have enabled 2 midi sends on the midi tracks and selected the vst plugins but I’m not getting a midi signal to pass into them. If I set the midi track main output to one of the single instances of SD3 it works fine, but midi sends are seemingly doing nothing. And to confirm again, I do have them enabled and output to both instances of SD3. Is there something else I need to do?

As an FYI, I’m using 2 instances of SD3 because with the release of the Area 33 - Origin kit, any additional instruments or routing will max out the SD3 mixer channels, so I had to split the kit up. Toontrack did not think that one through lol

Hi,

Is it the same issue as described here?

Could you reply the same questions, please?

Based on their description, I don’t believe it’s the same issue. That poster says their sends work but then randomly change destinations and have to be reassigned. I can’t get mine to send midi at all via the midi sends feature. Also I’m on Cubase 13 and that issue was reported on 12.

Hi,

Could you attach some screenshots, please?

I would like to see the Send slots. Then I would like to see the MIDI Input of the 2 SD3 tracks.

Could you add MIDI Monitor MIDI Insert to the SD3 tracks? Can you see incoming MIDI data, please?



So a bit of an update here. Once I add midi and then play it back, it does work as expected. The problem though is when I’m editing the midi and adding notes, I can’t hear anything. Maybe I’m misunderstanding how midi sends work, but is it completely tied to playback only? So I can’t send midi through while editing and it only sends on playback?

Hi,

I’m not with Cubase, now. But there is some kind of preference. I don’t remember if it applies for MIDI Inserts, MIDI Sends or both. Try to find the preferences, please.

That was it! There was an option to audition through midi sends and now it’s all good! Thank you for pointing me there!

1 Like