Cubase 13 not recognizing my behringer interface

Hi everyone!
I’ve been using Cubase for the past couple years on my mac. IT recently stopped working and I’m in the process of buying a new one, however I still don’t have the budget to get it. In the meantime, I tried installing it on my pc so I don’t get too delayed on some projects I’m working on but for some weird reason it is not recognizing my interface as an audio device, so I’m unable to record anything.
I have a Behringer UMC 404 and when I plug it in, my laptop recognizes it. I’m able to use it as input and output in different apps but when I go into Cubase, and in the Studio Setup I try to select it as my ASIO driver, it’s not there.

I’ve tried closing and reopening cubase, unplugging and plugging in the interface, restarting my laptop, checking from the control panel that the interface is recognized as an audio device and making sure all its drivers are up to date and trying different USB ports on my laptop. Nothing has worked.
Does anyone have any idea of what might be wrong and any way of solving this issue?

Did you install the ASIO drivers?

https://www.sweetwater.com/sweetcare/articles/behringer-audio-interface-setup-guide/

oops… edit:

UMC 404 has a download page, https://www.behringer.com/behringer/product?modelCode=0805-AAM

1 Like

I actually was on the same page as my pal Steve here and thought Behringer didn’t use any kind of drivers for windows but we were proven wrong!

Thank you both for your help

1 Like