Cubase 13 - startup VST3 checking licenses

This post was flagged by the community and is temporarily hidden.

And 7+ mins into this startup load…

We are now presented with:

So, all that time and now my iLok Cloud session is moved over.

10 minutes in and still no on screen indication of what is happening, but now we get just an initialization update…

And then a minute later it ran through all the plugins, content, etc.

Elapsed time: about 12 minutes +/-

And wow, 4% of cpu resources just to sit here…? Still “Checking Licenses” apparently…

Entirely inappropriate, and easily refuted by a perusal of the forum.


It’s appropriate. Show me where the product management team are… Not support people, but the product managers…

All over this forum, countless posts past and current indicate literally - users do not feel heard or listened to. I am certain its a lack of product managers to do the job, and usually it is some understandable approach to stay under the radar as to not get then emails sent to PMs directly.

Again, if they had enough, or an assemblance of a thoughtful UCD program not one single user would ever comment… “Its like they dont care or listen to us”.

Now back to the actual primary issue posted. Not the underlying secondary issues some like to focus to sidetrack a post about an actual program issue in 13.

I fully understand you are upset but this kind of rant will make folks steer away from helping you dude. FTR im not here for a keyboard fight.

I take it you are lauching C13 on dirty preferences? Have you tried removing cubase 12 pref’s?

My take is this, if cubase is getting stuck on lauch is highly likly you got something (plugin/Corrupted pref’s) that is holding up C13 on launch.
Sometimes these things happen my friend and as frustrating as this is, it happens. you are working on a windows platform so you should fully understand how this works.

i am not defending Steinberg as they do have a track record but we as end users have an obligation to exhaust all possibilites before jump on forums and giving these guys a hardtime.

I hope you find a speedy resolution to this.



Hi @Dayz_K

I think answering you within 4 hours and early in the morning shouldn’t have led to such a statement. We understand your frustration and we do read either praises or rants daily on this forum. However, we will not tolerate any profanity against our staff on this public forum.

I’ve read through your post but I’m not sure I understand what you’re pointing out. So Cubase is hanging for several minutes when scanning VST3 Plug-ins correct? If yes, understand that Cubase has very likely little to do with how long those plug-ins take time to load. If I understand you correctly, you would like to be provided a more granular type of feedback on the splash-screen during this initialization correct?

That being said, we are actually considering to profile and optimize loading time in the midterm with the help of our usage loggers and to get a better grasp at what could be improved here.

Thanks for your report