Cubase 5.1 recording ezdrummer tracks separately

Hi everybody,
maybe this question has already been answered by the forum is huge and I have not found what I was looking for.

I’m struggling with recording ezdrummer tracks separately in different audio channels. Not sure if youtube link are allowed, so I will explain the procedure I found:

  1. from vst instrument panel, click to enable all outputs (as midi tracks);
  2. create N-busses /as needed from ezdrummer) in the output vst connections menu (let’s say 3 mono and 3 stereo), setting the port as not connected;
  3. for each midi drum channel, link the midi channel to the relative audio channel;
  4. for each audio channel, choose as input the relative output bus created previously;
  5. set track ready for record, and hit record button.

Step 4 is my main problem: I cannot see output busses as input, and it seems quite unusual (other google searches on how to do this result in pretty much the same procedure).

Anyone can help? It’s a problem of my cubase version? I’ve to set something that I do not know in some place that I do not know either? Do you know another procedure to do that?

Thanks

But not for Cubase 5.1

So basically this feature is present only from cubase 6 on? I’m pretty sure I’ve seen it in a video in which a cubase 5.1 user used that but of course I can be wrong.
So the only way I can achieve this is through groups, by routing midi channel to group, and then using group as input for audio channel right?? What a pity.

Thank you

I´m sorry, I was wromg it also works in 5.1, I was under the impression, the whole “record from busses” feature had been introduced with a later version.

Thanks, so basically my question is still valid: how can I do that? Why I cannot do that?

Thanks

Brcause you´re doing something wrong.
-You can not usr stereo inputs on mono tracks (or vice versa not exactly sure atm)
-you must not create a feedback loop of any kind. That is also the case if you have send routings)
To name some points.
What exactly are you doing

Steps that I’ve followed:

  1. created 7 output busses (3 mono, 5 stereo) without routing them on audio card (so they are not connected);
  2. created (through ezdrummer) 7 midi tracks (Kick, Snare, HH, etc)
  3. routed each midi drum channel to the correspondant audio bus
  4. created 7 audio tracks (3 mono, 5 stereo)

At this point I wanted to route the output busses as input for audio tracks, but cant make it: the only input options for audio channels are “no bus” and “input”.

If I use group channel at point 3 (instead of audio bus), than I can use the it as input for audio track.

II can’t really understand what and where I did something wrong.

Any ideas?
Thanks

BUMP.

I guess no one can help?

I tried doing what you are describing a few times and instead found a workaround. It takes a few minutes longer but it works.

What you are trying to do is get separated drum tracks from EZD so you can edit them in Cubase. Did you try this: exporting/saving your EZD tracks as a MIDI file, then go into the Mixer section of EZD. Create your audio tracks in Cubase as usual (snare top, bottom, OH etc). Then, individually export each track as a WAV file from EZD, save on your hard drive somewhere and then import each onto its corresponding track in Cubase.

The trick is that in the EZD mixer section, you need to solo each track before you export it. Also, for the mono tracks (snare, kick, ambient mono, etc) you need to slide the pan control at the top ALL THE WAY LEFT (or right, whatever) to make sure the track only records on one side.

It’s kind of a pain, but it has worked for me.

If you have found a REAL solution – recording directly from EZD to Cubase tracks, please post it!

This is how I do it using EZD2 in CB8.5. The same procedure works using CB LE4. The procedure is for EZD2 not the original EZD version. Although the procedure may be the same. If you try it using the original version of EZD please post the results if the procedure works or not. Thanks

https://www.steinberg.net/forums/viewtopic.php?f=226&t=87028&hilit=ezdrummer

Regards :sunglasses: