Cubase 5.5.3 Windows 7 64 Bit Timing / Latency issues

Just trying to get a basic working system, attempted this a while back & got little response so never got it resolved. Trying to pick up and nail the problem this time - hope someone can help!

Scenario:-

My external Synths / drum machines & how they are midied together hasn’t changed, I’m even using the same 24/96 sound card.

However I have a new PC & now Cubase Software. With my old software and low spec XP Box all ran brilliantly…

Win 7 Pc has virtually nothing except Cubase on it, I do have a Virus checker installed with least aggressive settings I can. AVG 2011 but that’s about it

Various midi synths & drum machines are connected but not my MIDISPORT 2x2 Anniversary Edition yet.

Create a new project in Cubase with just a few tracks. When I select a track which is assigned to an external midi Synth I play a note & the response is instant. Gr8

I have perhaps 2 Cubase own Vsts assigned to tracks too

When I click ‘Play’ on the transport so I can play along / record a riff - straight away there is latency. I hit a key there is a slight delay before it plays. It’s driving me nuts! & renders the whole lot useless

I did make a few of the recommended tweaks to optimise the performance of the Pc but not loads – I am an IT Pro so I wasn’t dabbling randomly just following some advice I read in an article / Cubase docs

I did a few BIOS changes, some changes around the midi settings in Cubase and tried various buffer settings but nothing cured the problem

I can’t believe it’s a Spec of the Pc thing as the spec isn’t bad & is pretty much a fresh install

I have run the DPC Latency checker & although I can’t remember the values the status said this Pc can play / record Audio without dropouts

Can’t afford to upgrade to 6 yet in case anyone suggests that!

Hugely grateful if someone can suggest a fix

Try toggling Constrain Delay Compensation. Also, investigate System Timestamp and Emulated MIDI Ports.

with your “old software” it all worked fine but now with Cubase theres latency…what was the “old software”?

I had midi latency issues forever until i dumped the crappy old core duo and xp and went for a kickass 6xcore with Intel MB and 12 gig of mem with Win 7. no more midi latency problems.

you can investigate system timestamp and emulated midi ports until you are blue in the face and pulling your hair out. and the problem will return.

the problem is your pc is crap man. and cubase taxes the CPU more than your “old software” did…buy a new PC and the problem will be gone forever, its exactly what happened to me. then move on with your life and making better music…

Thx for the reply. I think I have ‘dabbled’ with those settings in the past - could you give me a bit more direction on what I should be aiming for / best ways to configure etc?

I assume there must be a preferred approach rather than just keep dabbling until / if the problem goes away?

You don’t give specifics as to how everything’s connected to the system or if you’re using external sounds, VSTi’s or a combo of both so being more specific is impossible. Change one thing at a time and try it is the best advice I can give. There’s a MIDI timing article in the Knowldge Base re: Timestamp and Emulated Ports.

Hi, I did mention both - perhaps I was not specific enough?

“My external Synths / drum machines & how they are midied together hasn’t changed”
“I have perhaps 2 Cubase own Vsts assigned to tracks too”

Do you mean ‘exactly’ how they are connected - routing diagram etc?

I’ll try and summarise it for you but my main point is that that side of things hasn’t changed - my previous (& much simpler DAW software) was running a P4 Pc with 3Gb Ram connected to the same hardware using the same midi lead etc and I had no latency issues. It was a slower Pc running a drastically simpler software but used the same soundcard & I had no probs

Plugging in a much faster Pc - ok running a more demanding O/S and a pretty huge DAW like Cubase ‘surely’ should be able to work perfectly midi-wise. If I load 100’s of Vsts then fair enough I need more RAM as its going to struggle

Summary:-

I have a fair few external hardware midi Synths & modules plus a few drum machines. They are all connected up to the M-Audio 24/96 in my Pc using a 4 port Black Box Midi thru. I have kept the midi routes as a short as possible so about 3-5 synths from one Midi port if I remember rightly

The Audio for them all goes thu 2 patch panels & 2 small mixing desks. Into / out from the M-Audio 24/96 in my Pc

As I said this hasn’t changed. No additional synths - no re-wiring. With Cubase loaded but the project running the timing is perfect anyway - it only goes wrong when I hit play/record

The things that have changed are:-

1/ The Pc
2/ The O/S
3/ The Software (Cubase)
4/ The driver for my M-Audio 24/96 - it’s using the latest Win 7 64Bit driver there is

It’s got to be one of these - surely?!

If I need more RAM then fair enough but I didn’t think it made that much difference to midi timing especially with mainly external instruments and only 2 VST’s runnning. Unless of course Cubase eats huge amounts of resources

Also, I know I have the MIDISPORT 2x2 Anniversary Edition which will double up my midi channels & probably sort my problem but I feel this setup should ‘at least’ be able to match the performance of my old crappy setup. Once it does I will add it to make it even better

Hope that makes sense

How would anyone possibly know “how they are MIDIed together”?

Have you tried any of the solutions I posted?

I didn’t post detail of how they are connected initially as the configuration of it hasn’t changed so I ruled that out as being at fault. Obviously you couldn’t figure out how it was setup from that

Would you agree that on the face of it the problem is most likely to be with:
1/ The Pc
2/ The O/S
3/ The Software (Cubase) - configuration issue
4/ The driver for my M-Audio 24/96 - it’s using the latest Win 7 64Bit driver there is

and not the way the external gear is physically connected up via midi leads etc?

Have you tried any of the solutions I posted?[/quote]

It was a while ago but I’m pretty sure I tried Constrain Delay Compensation & System Timestamp settings but it didn’t fix it

I haven’t had a chance to retry but I will do & report back

I do appreciate the input

Well, the reason I asked the signal chain is that I know which pieces of kit require which setting which would let me more specific about your issue. Obviously it’s a setting on something that’s changed. :confused: Go through the three things I mentioned one at a time until you find the solution.

I’ll need to test it out for longer to be 100% but I think I’ve cracked it… :slight_smile:

1/ Anti Virus software: Read that AVG was resource hungry & Avira was lighter. Switched

2/ Buffer size on my 24/96 Soundcard was 256 - changed to 128 (I played with this b4 & it didn’t help but since read that 256 was probably a bit high)

I ran DPL latency checker at this point & with Cubase running all fine. However, I happened to leave it running when I exited Cubase & it went RED!!! & gave this error

“Some device drivers on this machine behave bad and will probably cause drop-outs in real-time audio and/or video streams. To isolate the misbehaving driver use Device Manager and disable/re-enable various devices, one at a time. Try network and W-LAN adapters, modems, internal sound devices, USB host controllers, etc.”

I remembered there was a "Realtek nw Pcie Gbe family controller" driver update on Win update I hadn’t applied. Initially I thought that might screw things up more if it wasn’t the right thing so I left it

3/ Applied the update. Bingo! Sounding good…

8 tracks loaded 2 of which were Cubase Vsts - rest were external midi instruments (Synths). Admittedly a few synths mad no sound which is weird I’ll have to investigate that seperately but the rest worked fine & I could play along with cubase running without any obvious latency

Task Manager showing my 4 core CPU at a measly 4% Used & 1.3 of 4GB Ram being used so no stress there! (That should answer the ‘your Pc’s crap’ line of reasoning…)

DPC reported no errors with Cubase running or after I exited it. with it running it showed a current Latency which flicked between 33-43 and an absolute Max of 256.

Not sure if that’s good or not but according to my ears things are ok

I will retest properly in case it was a blip & goes pear shaped again but looking good

If it stays fixed I guess it’s fairly specific to the hardware you have & Realtek are one of those mentioned but I found this on tut web which I thought I’d share:-

http://www.sevenforums.com/sound-audio/22369-realtek-windows-7-64rtm-crackle-static-popping-32.html

The salient bit:

“The problem is caused by bad drivers from realtek; interestingly not the audio driver though. It is caused by the Ethernet NIC drivers. Please run Windows 7 update and acquire the new “Realtek PCIe GBE Family Controller” drivers. If this does not solve your problems make sure the “High Definition Audio Controller” and “Realtek PCIe GBE Family Controller” are not on the same IRQ number. The problem is caused by the Ethernet NIC using too many resources from the IRQ and when this is the same number as the audio card sound gets choppy. You may also want to try to uninstall the “Realtek PCIe GBE Family Controller” driver and re-install them. Switching IRQ’s is a pain in the butt in Windows 7 and I have not found a fool-proof way of doing it. I was lucky to have two Ethernet NIC’s on my motherboard and one happened to have a different IRQ.”

but also

“not just limted to RealTek.”

“…share my findings on what I believe to be a Windows 7 IRQ issue. Again, if anyone knows how to switch IRQs manually in Windows 7 (settings in my bios do not affect it) I would really appreciate the advice. It would help if this problem occurs again with future hardware.”

Thanks for your input…

Seems pretty fixed to me :slight_smile: must have been the Realtek driver