Cubase 5 and Behringer


Please guys help me, Im struggling with that problem for over a month, I have Behringer x Touch Compact, and I use Cubase 5 Full Version, Im on mackie control, when I opening Cubase lets say with empty project and then just add Instrument track (Halione one for example) then its automatically assigned first fader to volume and last 9th fader to main volume, everything looks good BUT… whenever I try to assign 2nd fader lets say to Resonance wheel in Helion one or any others even in KONTAKT , it is responding but fader is going back to zero after touch, and Resonance jumps from 0 to 127, its not moving with my movement and it doesnt let me. I have tried with generic mode to assign faders, I have tried with quick control, still the same. Cubase recognize fader but doesnt let me to move and stay in the same position when I leave. Basically I cant assign any of faders properly, After assign it event I only touch it not even move , the resonance or even dynamic after assigned jumps from 0 to full 127.

I assume that there must be something to tick but I don’t know where it is, as in Ableton I had the same issue but after I have ticked synch and remote In device setup, I could do anything with faders and they didn’t come back to 0 or 127.

I hope I have explained that clearly.

Many Thanks for any replies