Cubase 5 ASIO Meter Problems

Hey, guys! I have seen a few topics similar to my problem, but none that entirely helped me solve my problem. I’m working on a pretty big project with effects being routed and automated this way and that. It is a hefty project, but I do know that there are people out there making much larger projects as well. I have a high performance HP computer, so I’m certain my computer specs are not the problem. The ASIO meter in this project sits around 90% at all times and peaks during big parts (especially during busy drum fills if that helps). I’m using a TC Electronic Impact Twin (http://www.tcelectronic.com/impact-twin/) as my audio interface. I also just bought a better TI Chipset last week thinking that would help my issue (http://www.newegg.com/Product/Product.aspx?Item=N82E16815124107&cm_re=pcie_firewire--15-124-107--Product). So far, nothing has helped at all. Do you think investing in a better audio interface would help? Would upgrading to Cubase 7 or 8 help? Thanks for any and all help!!

Hi and welcome,

I think, you should increase your Buffer Size (latency). Open Devices > Devices Setup. Under the VST Audio System, select your ASIO Driver. Then on the right-side, click the Control Panel button. Control Panel of your sound card appears. Find the Buffer Size (or Latency) parameter, and increase the value.