Cubase 5 Disk performance problem

Hi! Bought and installed Cubase 5 in october and have had a problem with the disk performace since. Everytime I click fast forward, rewind, or click the timeline to go to another part of the song, the performace meter goes up to max (lights up red) and there’s a delay for about a second before the computer works like normal again.

The computer is a 8-core 2009 Mac Pro and interface is SSL Madi Xtreme 128. The audio drives are two 1TB Samsung Spinpoint F3 (Raid 1). I have tried different buffer settings, but nothing changes. The Madi Xtreme drivers are the latest, and everything worked great in Cubase 4.

Any ideas would be very welcome as this is really annoying.


Are you seriously in RAID 1?

Running on 1 drive with a mirror is the worst possible performance for an audio system. However, the lag sounds more like a sync issue with an external controller or something. Do you have another device hooked to the MADI?

Not necessarily.

He wrote that he uses two 1TB drives in a RAID 1 configuration. In theory, this may up to double the read transfer rate (see Wikipedia reference here).

About write performance, this depends on whether a synchronous or asynchronous (lazy) write strategy is used, where synchronous is slow (has to wait until write requests committed to both disks) but safe, while asynchronous is usually fast but may lead to data inconsistencies in case of a power failure, unless a hardware RAID controller is used that provides battery-backed or flash memory.

To find out whether or not the RAID 1 is the culprit here, I recommend to use one of the various available disk benchmark programs.

Sure I’m familiar with what RAID 1. However, I think you will find that for audio processing, it is a bad choice unless you have the absolute top of the line RAID controllers. Typically the ones on the MB are either software solutions or very poor hardware solutions. The overhead of splitting/copying/merging data from the controller can be a real problem for normal workstations.

But, like I said, it sounds more like he has something connected through his interface, like an integrated mixer, that could be causing the problem. However, he didn’t say if he had anything connected to the interface or not.

The only thing connected to the Made Xtreme is an SSL Alpha Link AX (MADI and wordclock (computer/xtreme as master clock)). I moved a project to another (non raid) disk today, and it’s still the same problem. The only other things connected to the computer is Syncrosoft dongle, Ilok, mouse, keyboard and a couple of USB disks. The strange thing is that everything worked great in Cubase 4.


hmm… it does sound like a sync issue, but I don’t know how to walk you through some troubleshooting for it. And, I could be totally off base and it could be video card drivers, or something equally stupid. Sorry about that.

Hi !

Know nothing about this but I do have sync issues with my hardware and Cubase if using external SSL clock. Sounds good but some jitter…

…maybe SSL gear ? I do not have any sync / jitter problem when SSL stuff are connected to Cubase as a slave to the clock or analog.

sorry I cannot help more.


Have you tried disconnecting the interface and running internal audio only?