Cubase 5 missing parts of recorded track


I really hope someone can help me. I am using a Peavey Vypyr 75 amp for recording in Cubase 5. The problem is everytime I listen to a playback, parts of my tracks are missing (track is kind of broken), and it seems like Cubase is bugging. On my older PC, track would start realesing noise instead of sounds I recorded, but then would come back without even changing a ryhtm. Does someone know what can be a problem??

Hi and welcome on the forum,

Are the Audio Parts/Events missing visually or are there an audio dropouts?


Thanks for a quick reply. Well I don’t get any pop-ups like users usually experience when they have audio droppouts, and my track doesn’t stop completely but simply jumps to the next part of the track and kills the rythm and everything. When it comes to an audio parts and events, I am not sure. I do see like broken track like nothing is recorded, but that part of the track usually plays my recording anyway (most of the time). To be honest I don’t have a lot of knowledge in recording music, but this problem is kind of unchanged regardless to what kind of PC I use. Sorry for the long post.


Could you try to increase your Audio Device Buffer Size, please?

Hi, I am sorry to answer a few months after the discussion. I increased the buffer size from 2048 to 2500 and even tried 3000, but nothing has changed. Is it possible that I have a very weak sound card?


Could you try to test your system by using LatencyMon?

I just did. It says that the system is suitable to handle real-time audio without dropouts. Also, I started getting the message when I open Cubase that the currently installed sound card driver does not support Direct Sound Input. Recording audio is not possible.


Could you try to use ASIO4ALL instead?

I installed it even before Cubase and it’s enabled on Cubase.
There are 3 options:
-ASIO DirectX Full Duplex driver (this one is selected)
-Generic Low Latency ASIO driver


How does it work with ASIO4ALL, please?

Same. When I started this topic here ASIO was already enabled on my Cuabse.


Lets go back, please.

What exactly do you mean by this? How does it look like? Could you attach a screenshot, please? How does it sound like?

When I record a track with my guitar and play it again it sounds choppy, there are parts missing so it jumps to the next part of the track and changes the rhythm because of that

. Also, my ezdrummer track that I recorded( which used to work until now) is there but simply cannot be heard. I’m getting this message now: Impossible to record audio because Audio Input is not active. Open the ASIO DirectX Sound Full Duplex Setup Dialog. Make sure that a device is selected in the Input Ports section and that its check box is activated.


The ezdrummer plug-in is quite CPU hungry.

I would switch over to ASIO driver, i.e. ASIO4ALL (at least) and I would increase the Buffer Size (significantly).

Your waveforms look complete (though I could be seeing it wrong) which would mean your audio likely records fine, it’s your playback that’s messing up. In the Device Setup menu see if you have ASIO guard enabled (I don’t remember if Cubase 5 has that), if not turn it on, or mess with those settings. And while you’re there make sure multi-threaded processing is on. I remember older versions of Cubase had a lot of this stuff turned off by default.

Also an old destroyer of performance is the “Enable Record on Selected MIDI track” or “Arm selected MIDI track for recording” whatever it was called back then, turn that off and see how things run.

Yes, the playback is messed up. Thanks, I’ll try to do those things and hopefully, it will work.

Hi, me again. I tried everything suggested here in order to try and fix the missing and jumping parts of the playback track, but nothing helped. I also saw a lot of older posts where people complained about the same problem and no one actually managed to fix that. So I am wondering why Cubase works fine on some computers and yet doesn’t work well on others…If someone here has another suggestion I am more than willing to hear it out since this is going for a few years now and it’s beyond frustrating. The same problems are happening on Cubase 5 and Cubase 8 both on my old and my new PC.


Have you tried the LatencyMon utility, please? What was the result?