CUBASE 5 on Yosemite upgrade to CUBASE 7


I’ve been using Cubase 5 for 4 years on iMac with OS X 10.5.8.
Few weeks ago I decided to spend some cash and buy new computer and upgrade to Cubase 7.
I bought a MacMini (late 2014) and the upgrade CD to 7.5 for Cubase 5 and 4.

Little did I know that I’ll get a MacMini with the OS Yosemite 10.10 which can not run the installation for
Cubase 5. :open_mouth:
So, now I’m stuck with the newest MacMini and the latest OS Version, but can’t use Cubase at all!

I know that Steinberg released the Installation Tool for Yosemite, but still it’s now applicable to Cubase 5 installation.

Does any one have an idea how I could solve this problem?

How about partitioning your MacMini’s hard drive ?

Then install Mac OS X, 10.5.8 to that partition and then install your Cubase 5 to the new partition.

That means you will have boot into the partition that has Cubase 5 to use Cubase 5 .

Also you should be able install your Cubase 7.5 to the same partition. Now you can use both on the same drive ( not at the same time of course ).

This new MacMini that I bought came with preinstalled Yosemite already.

I tried booting it with a bootable USBs that have OS X 10.8 and 10.9 on it, but it wouldn’t boot.
I tried to partition the HD, which is FusionDrive by the way, so I could install the older OS X version on it, and still it wouldn’t let me run the installation for OS X 10.8 and 10.9.

Then, when I run the Startup Manager, I used Disk Utility to erase the HD and tried to recover it from the bootable USB.
After that the Mac wouldn’t boot at all! - what happened is that I erased everything on HD and couldn’t run the Mac on an older OS X version that was installed in that way and couldn’t use the computer - the grey screen with circle and a line would appear after which it turns itself off.

I disassembled entire Mac (good buy warranty), took out the HD and connected it to MacBook Pro via Thunderbolt-FireWire cable to try to install OS X 10.9 that way. After installation, I put the HD back, but the Mac wouldn’t boot.

I restarted it, connected the Time Machine HD to which I made a backup before I tried any of these approaches, and restored it to it’s previous state.

So, now I can boot it, with a Yosemite running on it… but still can’t use Cubase 5, nor upgrade to 7.5!

In the end, I read somewhere that the problem are actually drivers for the components used on the MacMini late 2014 which exist only on OS X Yosemite and not the older OS X versions.

I turned to Apple and asked for assistance - I was said that it should be expected from Steinberg to come up with a solution in a couple of months - meaning
they should develop some kind of another installation tool or an update or something 3rd…
I sent e-mail to Steinberg yesterday, asking the same thing, but they haven’t replied yet.

I found that other users experience the same problem with Cubase 5 and Yosemite…

Wow, what a pain in the studio.

If you have Cubase 7.5 you should be able to install that to the hard drive that has Yosemite by using Steinberg Application Installer Tool for Yosemite

I was able to install Cubase Elements to Yosemite.

I’m still waiting for Steinberg to address the issue of installing Cubase 5 to Yosemite.

Personally, I do not understand why it’s such problem installing Cubase products to Yosemite. I did not have any problems installing and using other midi/audio/video programms such as Logic Pro 10.0.7, Final Cut Pro, Sibelius 7.5, Digital Performer 8. Obviously it has something to do with Steinberg’s copywrite protection system. It makes me mad that here i have a Cubase product that i have used for years and now suddenly can’t. Surely, Cubase was aware of the new Mac operating system.

Used my own solution:

simply copy the programme including the preferences from another external hard drive.

Aloha W,

IMHO…ain’t gonna happen. But never say never.

Good Luck

Exactly, because they only want to sell the latest version and no doubt consider Mac Cubase 5 as legacy because it can work with Mac PowerPC and Intel Macs. How many Mac Power PC users are still left ? So why worry about us that still have and like to use those legacy computers and software ?

IMHO there is always a silver lining.

That is, if that old stuff is still working then screw updating/grading.

Just keep using the old stuff.
Your sound will be as good as the day you first set it up and got it working.

We still have SX3 running on a G4 laptop just fine;
I have it set-up at church for 2 track stereo choir practices.


Interesting/interesting use of Cubase SX3 software. Do you use backing tracks for “recording” sessions ?

I still have SX3 running on my G4 QuickSilver as well as various versions of Cubase VST’s — score on my other Mac legacy computers ( such as LC520, Performa 6360, and G3 (blue jelly bean).

In fact there are many features in those old Steinberg apps that just never were ported over to the Mac OS X operating system.

I tried the same: copying all cubase 5 related files i could find from my old imac to my brand new macbook. I kind of works, but not really: i have problems with clicking on buttons, very annoying. The Cubase interface does not seem to react always on mouse clicks in Yosemite. Maybe i forgot to copy some essential files, although Cubase does not give any kind of error message. Maybe Cubase 5 uses some kind of outdated interface technique.

That’s why i’m interested in your post: you really got Cubase 5 working by copying all files by hand?!

I found this: Cubase 5 cannot work with Retina display resolution. That explains the strange problems I have!

Thank you for sharing that information even though I don’t yet have a Retina display Mac.

I also found another work around for installing Cubase software to Yosemite: I have used Mac Pacifist ( ) and it works much better than the drag/drop/copy method which can be a bit tricky in Mac OS X.

Hi guys,… same here.

I had it installed, but now my sound card is crazy. It works normally, but when I hit a key on my midi keyboard,

there comes out a noise like TV static or distorted white noise.

Any ideas on how to fix that?

I have my Komplete Audio 6 selected and the buffer size is around 500 something.


WTS you star! I just copied Cubase 4 from my time machine drive onto my macbook with yosemite and HEY PRESTO IT WORKS :slight_smile: :slight_smile: :slight_smile: Thank you!!