Cubase 5 records blank audio

Hello,

So i used Cubase 5 since it first appear on the market and i never had this problem. Well, recently i installed Win 10 on my PC and today i wanted to install Cubase 5 on it. I’m using the same audio interface as before (Focusrite Scarlett 2i2). However, Cubase worked perfectly when i had my old Windows installed but i don’t know why this happens. Basically i plug the cable in my guitar and i hit the monitor button, i can hear it but when i try to record something it records BLANK audio. I tried to record through my Creative Soundblaster Audigy SE with ASIO4ALL but the result is still the same. I will attach some images showing my problem, when i had my old windows installed i was using exactly the same settings as in the pictures.

If anyone knows a solution to this problem please tell me.
screen 4.png
screen 2.png
screen 1.png

Well, it turned out that it was Win 10 fault. The new Win 10 asks you for your permission for everything you, especially when you’re editing something in the partition where Windows is installed. The problem was that Cubase is not allowed to create any files in C partition (where my OS is installed) because Windows 10 doesn’t let it, that’s why every track was blank, there was no information written on the hard drive. So i created a new project in the D partiton and voila, now it works perfectly.