Cubase 6.0.5 + MR816 = random "glitches" ?

I’ve had this problem for quite some time now, and no one, including the technicians at ADK computers (the company that built my pc) can figure it out. I’m using cubase 6.0.5 with the MR816csx, and “internal” clock.

I’ve done everything possible to try and stop these random digital “glitches”, or “hick ups” that happen no matter whether I’m tracking or mixing. It definitely isn’t a cpu issue, as I can be registering only around 20-30% load and out of no where the project will simply “skip”, if you know what I mean. I’m quite sure it isn’t a ram issue either as I just maxed out my mother board to 8 gigs. I know that’s not a lot, but certainly enough to handle my projects.

I also recently upgraded to a new UAD-2 card, upgraded from XP pro to Windows 7 pro (well, the guys at ADK computers did most of the work remotely), all firmware, drivers, mother board bios, etc. are up to date, and I STILL get the “glitches” ever so often.

The main tech at ADK stated that it wasn’t a video card issue, and that it sounded like it was a MR816 firmware issue,… that I had to make sure that I had the “Legacy” drivers. I checked and I do indeed have those.

This has been going on for months and months, probably close to a year or more. It isn’t bad enough to stop me from working, but I’m so big time sick of it! I haven’t added anything to my set up that could possibly cause this,… at least that I’m aware of.

The only thing for sure I can say is that when the “glitches” start, and become more and more “consistent”, I can either LOWER or RAISE the buffer in Cubase, and the problem goes away,… at least for a while. This is what’s so strange to me,… the fact that I can lower the buffer and the “glitches” temporarily stop. I would think that lowering the buffer should make it worse?

Could someone PLEASE help me figure this out?

Thanks for reading,

I had also this problem on W7 x64 with random drop outs which weren’t accompanied with any ASIO/CPU spikes. Then I found the well hidden “Yamaha Steinberg FW Driver Utility” (ysfwutility.exe). Increasing the IEEE1394 buffer size from “Small” to “Medium” solved my problem.

Best regards


Also sounds like a Firewire issue.
Which firewire chipset is you firewire card using?

Thanks,… I had no idea that setting was even there. I’ve changed mine to “medium” as well. The “glitches” are so random that it might take a few sessions to see if it helps or not. (fingers crossed!)

Not sure which chipset, other than the “IEEE1394 v1.02” listed within Cubase control panel. I’m pretty sure I have a compatible chipset though, since this was a custom built pc from ADK computers,… a VERY reputable company.

I wonder if the firewire cable itself could possible be the culprit?

Just look up your motherboard if FW is onboard, otherwise look up FW board itself.
The manufacturer will state what chips they are using.

marc…may I enquire as to whether you have any Native Instruments software installed?..IF you do, then Ill indulge in a lengthy reply…as I had similiar problems…and depending on which software I was using, I had to switch from using the legacy firewire drivers…(using the Mr8, with NI Traktor Pro for example was a no go!..

I use the Native Instruments Komplete 6. Just installed the Mojo:Horn Section (which of course uses Kontakt), and will be installing NI Session Strings Pro whenever it arrives.


OK, I’ll have to check the motherboard and see.

Just an update, in case anyone is still following this.

I “re-set” the firewire buffer to ‘medium’, as suggested. Since then I’ve had one long recording session, and a few mix sessions and so far no digital “glitches”!

Hopefully that was the problem,… time will tell of course.

Thanks big time for the tip!

I’m glad this worked for you, too! :slight_smile:

Best regards


Well, I may have spoke too soon. I was mixing this evening and noticed only one “glitch”, which is for sure better than before,… especially since it’s been a few days with plenty of mix work.

I changed the firewire buffer to “large”, just to see how that effects it. Do you think this sounds a bit extreme?, after all, this pc was built for audio, buy a very reputable co., ADK computers.

I suppose that the only bad thing which could arise from setting that buffer to “Large” is increased overall latency of your system (in case you don’t use direct monitoring). So, I think it’s okay to try this setting :wink: