CUBASE 6.5 and DUENDE NATIVE v4.0.6 crash

DUENDE Native SSL X- series are crashing when I re load a project… (see pictures attached)
X-Comp, X-Vocalstrip, X-EQ, etc… The X-Reverb seems to be working fine…
DUENDE Native SSL Channel Strip and Bus Comp are working fine…

I can load them fine but as soon as I save and close, and then re-open, CRASH… they stop working and no sound…

I just got these plug-ins… :astonished: aaaarrg! Been wasting a lot of time with this issue… I can’t use them at all… Way to go.
Contacted the tech support from SSL and waiting on reply…

ANYONE has this problem loading DUENDE SSL X-series VST???
X-EQ crashes over and over.jpg
X-EQ no recalling settings 2.jpg

No problem here, on Mac.

Try to update your Duende plug-ins, same as very stupid and complicated authorization application of Duende.

There were similar problem after Mac OS X update (to 10.7), but update solved them.

This is a known issue with the V4. Duende native X series VST3 plugs and Cubase 6 from SSL Support. You need to use the VST 2 versions of these plugs instead. I hope they will fix this as well

That’s what I found out… I only had VST3 installed… I removed the the VST3 and installed VST2.x


This thread has been solved… But hoping they fix the SSL Duende VST3