Cubase 6 has no ReWire option (32 bit)

hey there

im running cubase 6 & reason 6 on windows 7. all 32 bit. i have NO rewire option in the Devices menu…
how can i solve this?

Hmmm…

If Windows 7 is 32-bit and Cubase 6 was installed as 32-bit and Reason 6 was installed as 32-bit, then you should have the “REASON REWIRE” option available to you. Try the following:

  1. Uninstalling both Cubase and reason
  2. Reboot
  3. Install Reason 6 with updates.
  4. Install Cubase 6 with updates.
  5. Launch Cubase 6 and search for the "REASON ReWire " option under Devices menu.
  6. If its there, activate the # of REASON Rewire channels you with to use.
  7. Launch Reason 6.

Good luck!

thanks for your replay…

does it matter in wich order do i install them?!

uninstalled everything and reinstalled

still no rewire

http://imageshack.us/f/703/63588961.png

please guys anyone?

i cant seem to find any solution and this is really strange as it is
why cant i run rewire if everything is 32 bit? why does the ReWire option is not even there?!

i cant work !! what do i do?

How did you verify that both are actually 32 bit? What steps during installation did you take to make sure you got only the 32 bit versions?

Your Windows version could be either 64 or 32, doesn’t matter here, though I would think that the installer would only install the 32 bit versions automatically on 32 bit Windows. Shouldn’t be an option for 64 bit installs.

I’ve got 32 bit Cubase 6.05 and Reason 6.02 rewiring just fine here, but on 64 bit Win 7.

Do one thing for me. Go to Start, bottom left. Then from the menu right click on “Computer”, select “Properties”.

In the dialog that pops up, what does it say after “System Type”?

Another troubleshooting step would be to install both the 32 (and 64 bit, if it will let you) versions of Reaper, free shareware, 8 mb installer. It can run as a rewire master or slave for both 32 and 64 bit as well as bridged… If it shows up in Cubase, note which version it rewires to, also if Reason shows as a rewire slave in Reaper, we can go from there.

http://imageshack.us/f/819/windowsn.png/

im sorry, its in hebrew buy ive marked the 32 bit part

and i cannot install 64 bit versions… only 32 (it doesn’t ask me at all so assume its 32. cubase says it right on the startup window but reason for some reason (lol) does not state if its 32 or 64

Ive had a hard day, so go easy…


go to windows/system32/ & look for rewire.dll


is it there?..or so you have 2 copies…(right click properties, your looking for the latest version…delete the other one (if you have 2)…

Then do this if you have other install directories:

(Before you do the following, you must make sure you have “Show hidden files and folders” turned ON and “Hide file extensions…” and “Hide protected…” turned OFF (Folder Options window))

Open a Search windows and type in [rewire,rex] to find all files with similar names. In “Look in” select your hard drive (here’s an example of how to select more than one partition/folder to look in: [C:;D:;E:\Program Files]). Mind that you have to point the Windows folder and the Program Files (and similar) folders to be searched. Some files will be found. Check out all [ReWire.dll], [REX.dll] & [REX Shared Library.dll] files. They would probably be found in these or similar folders:

C:\WINDOWS
C:\WINDOWS\SYSTEM (Win98,Me)
C:\WINDOWS\SYSTEM32
C:\Program Files\Steinberg\Cubase
C:\Program Files\Prpellerhead\ReCycle

The only folder they should be in is …\WINDOWS\SYSTEM32 So you will have to leave only one copy of each file in the SYSTEM32 folder

try to leave only the latest REX Shared Library.dll, removing Rex.dll. [REX Shared Library.dll] is the actual name, the REX.dll is obsolete. If this fails, leave the latest REX Shared Library.dll and the latest REX.dll.

Sort the files by name in the Search window. Right click on each found file to check out its version. Find out which are the newest versions and copy them in the SYSTEM32 folder if they are not already there. Rename all that remain (older ones, situated in different folders like just \WINDOWS, or \Program Files\Steinberg\Cubase) from .dll to .dll-backup to disable them. This way you will be able to rename them back if a program doesn’t work properly. If something doesn’t work copy the [REX Shared Library.dll] az just REX.dll into the SYSTEM32 folder. If something is still messed up - copy the newest REX.dll file to the SYSTEM32 folder.

OK, that’s it. Now test your apps and test if they work with ReWire, then try loading some REX Loops and such to be sure that all is OK.

i really thank you for your replay.

it seems i dont have a ReWire.dll in my system32 direcory.
infact, i dont seem to find a file with this name anywhere on my computer

and no “REX Shared Library.dll” in system32 as well…
wierd.

this must explain why i dont have ReWire option lol…

HELP :frowning: why isnt there any of the dll’s ? rewire/rex

this is really wierd

The path for rewire on my system is C:\Program Files*Common Files*\Propellerhead Software\ReWire
(not system32)

The rex shared library dll should be in the Cubase folder, but I think (could be wrong) is just so Cubase can read rex files, and has little to do with rewire.

EDIT: if you do find rewire.dll, you might try moving a copy of it so system32 to see if that helps. Mine is working without one in system32 though.

dude

that totaly worked!

copied ReWire.dll to system32
now it works just fine!

thank you for your response it was very helpful

wonder why reason did not moved it automaticly to system32

any clue why this didnt happen automaticly?

yeah…Its Propellerheads just fannying about cos, the world is mad at them for not updating Rewire to 64bit sooner!! :laughing:




just to add bro…my post was a file on record,as Ive had to accomodate a few peeps over the years (not updated to accomodate win 7 64) but Ill do it now…as If you cant work it out the answer for a newer O/S.then in my book you shouldnt be fiddling with Cubase. :laughing: