cubase 6/mpk49 wont play synths

first off let me say i do enjoy this program (cubase 6.5) alot. but i cant seem to get this mpk49 to work with cubase.
i loaded the xml file change the setting on the mpk to “cubase”.
it is registers on the red bar that cubase recognizes its there when i hit keys or pad on my midi controller
but when i hit the keys on my mpk49 it will never play a sound on the synth/vst and it wont record midi data either. it gets me so frustrated because i am trying to work on music but i cant because i have no keyboard to work with. normally i would just by a new midi controller but i lost my job a couple weeks ago so that is off the table…

please any help would be great i am willing to try anything and answer any questions you maybe have for me to help me.

You did select the MPK49’s as input source for the MIDI/Instrument track?
Or, when using “All MIDI”, did you include it in “All MIDI” (O.M. p. 21).

For what?

cubase capture.JPG
it the akai mpk49 cubase xml.

Not sure what you are trying to do with the generic remote (hope you don’t set it up per VST), but you have your MPK49 connected by MIDI to the Komplete Audio 6, right?
You do know the MPK49 won’t send out MIDI when the USB is connected and the driver is loaded?
More interesting to see is the “MIDI port setup” page

On a side note, I noticed, you have a Komplete Audio 6 but are using the Generic Low Latency ASIO driver. That’s odd.

Not sure what you are trying to do with the generic remote (hope you don’t set it up per VST), but you have your MPK49 connected by MIDI to the Komplete Audio 6, right?
You do know the MPK49 won’t send out MIDI when the USB is connected and the driver is loaded?
More interesting to see is the “MIDI port setup” page

On a side note, I noticed, you have a Komplete Audio 6 but are using the Generic Low Latency ASIO driver. That’s odd.

yes i have my mpk49 connected to Komplete.
i have it connected by standard mini in and mini out ports with Komplete 6, i even tried switching them around to see if i might have hooked up up wrong. also i just got the Komplete for Christmas and i have cubase for almost 4 months. so i had this problem before i had the Komplete
i have my mpk49 powered by a wall adapter not the usb would that fix what you mean by usb?

little extra background data:
the midi controller work perfectly fine in FL Studios, and with the stand alone vsts. Pro 53 standalone, absynth standalone programs… just cant seem to get my midi controller to work in Cubase.
where is the midi port setup that your talking about so i can take a screenshot? i dont see it anywhere?

on the side note like i said i got the Komplete for Christmas so i am still learning how to set it up since my mpk49 doesnt work i have spent all my time trying to figure it out how to get the mpk49 working so i am still a “noobie” with cubase.

Yep powering it externally is the right way when using it over MIDI.
You could also power it through USB and disable the driver from loading, but forget that for now :wink:

You said you saw activity on the MIDI input bar in Cubase, and it works in FL and on stand alone instruments. So I think it’s a small setting within Cubase.

When in Cubase you go to Devices -> Device Setup -> MIDI Port Setup, you’ll see a list of MIDI ports.
That’s the one I would like to see.
But you could also confirm yourself if the “Komplete 6” MIDI in has “In All MIDI” ticked.
Now when you setup a MIDI or Instrument track and select “All MIDI” or your Komplete 6 as input, all should work normally.
Unless you have specific wishes, setting up a Generic Remote isn’t necessary to play or control a VSTi like Pro-53 or Absynth.

just added the capture

yea pretty much tried everything to get it to work which is why i am on here because i am stumped.

edit i took the screenshot because it is still not working.
midi port setup.JPG

Hmmm… looks like it’s set up like it should be.
Is the MPK49 sending MIDI over an A channel, not B. So for instance Channel 1A (On the MPK: Global -> Channel)

channel is set to 1a. do i need to change it?
if i switch it to B on this display it will no longer register in cubase on the midi bar

No, should be on 1A not B.

Have you tried to loop the Komplete Audio’s MIDI port (MIDI cable from in to out), to make sure MIDI is working in Cubase.

Create 2 MIDI tracks in Cubase:

Track 1
input: none
output: Komplete Audio 6 out

Track 2
input: Komplete Audio 6 in
output: none

Put an event with some MIDI notes on Track 1 and arm Track 2 for record.
Record and see if the data from Track 1 is being recorded to Track 2

good news and bad news:

both in and outs are showing activity but no midi data is being recorded.
attached is a screenshot of the test.

i just “penciled” in the data on the piano roll.

also i just wanted to say thank you for all your help so far.
midi in midi out loop.JPG

Okay a long shot, just to make sure.
When you go to Preferences -> MIDI -> MIDI Filer -> Are all the boxes except SysEx unticked?

yes the are all unticked (no checkmark) except for sysEx

Okay, I’m running out of ideas. Another thing to try though.
You said the input meter shows activity, could you try to the “MIDI monitor” in a “MIDI insert” slot.
Be sure to activate “Inputs” in the MIDI monitor and “List Events” and “Notes”.
Now when you arm the track and play some notes, do you see any activity in the “MIDI Monitor”?

i tried what you said and nothing showed up in the midi monitor.

im starting to think its not my controller but for some reason cubase is not allowing me to record midi data for something reason?
maybe something is stopping it?

Does the Komplete 6 have MIDI activity lights? If yes, do they light up when stroking some keys.

To make sure Cubase is really the issue, you could try to hook up the MPK by USB.

ok i was playing around a little with cubase while i was waiting for you to respond heres what i have come up so far.

stand alone pro 53:
usb connection: works: as soon i plug in the usb it allows me to play with my midi controller (no setting changes needed.
midi connection: works: plugged it in via komplete. works the same as usb just plugged it in and it played (no setting changes needed)

Cubase:
**Cubase: usb connections : does not work :**it shows that i recognizes (red bar moves) that a device is there when i hit key but wont record midi, or play any sounds or synths.
midi connection: does not work: connected the same way as i did with the stand alone. again same as the usb be connection for cubase.

other cubase thing i noticed
i relooped my Komplete like you asked me to do before.
i made 2 instrument tracks with both being midi controlled.
used pro 53 as the “sounds” different ones for different track so i could hear if it would record.
if i penciled in the midi data i could hear the sounds as i was penciling it.
when i played it back with the play button i could hear the pattern.
but i could not record the data from the first midi track to the second no matter what in or outs i choose on ethier midi track.
i even tried recording the data as i penciled it in to see if that was they problem. and again it didnt record midi data.

so after messing around somemore it seems like for some reason cubase can reconize there is a signal ( both in the input bar and out (red and green).
but for some reason it wont record any data.

One thing.
When you go to Preferences -> MIDI -> MIDI Filter again.
Are the Channels light or dark?
Dark is enabled (good).

For now I’m out of clues, sorry.
You tried everything you can and yes it looks like a Cubase problem.
Final thing to try is to trash/rename the preferences and see if it makes any difference.

how do i trash my preferences?

Normally they are stored here:
%APPDATA%\Steinberg\Cubase 6_64

I would start by renaming the “Cubase 6_64” folder (not sure what it is on a 32bit system) when Cubase is closed.
And then start Cubase again.
I choose for renaming to keep the old files. You could also choose to delete it.