Cubase 6 trial won't download - have tried several times!

Hi Guys,

I’ve tried downloading the Cubase 6 trial version (for Mac) several times on different days (and different computers), but the link never seems to work.

Each time I just get this error:
Safari can’t open the page “”. The error is: “The operation couldn’t be completed. (NSURLErrorDomain error -1.)” (NSURLErrorDomain:-1) Please choose Safari > Report Bugs to Apple, note the error number, and describe what you did before you saw this message.

Has anyone else have this problem?


Have you tried a different browser? Often seems to help with stubborn downloads.

I had huge problems downloading the C6 trial for Mac. I ended up using Filezilla to down load it. Depending on your web browser (I am using FireFox 4), if you mouse over the link to download the trial, right click and choose Copy Link Location. Then paste into Text Editor. In the link you will see the FTP server, user name and password. The link format goes like this ftp://:@/ In my password, there was a space at the end which is shown as %2E since it is URL encoded. Just use those in FileZilla. Even in Filezilla the transfer would crap out but you can resume it. Whenever it crapped out, I would wait about 5 minutes and then start it back up.

Painful, but it worked to get the trial downloaded.