Cubase 6 upgrade from C5 problem starting up.

I installed everything, then when trying to open C6 I get this message…

“The application failed to initialize properly (Oxc0150002). Click on OK to terminate the application.”

I hope this is an easy fix.
Thanks in advance guys.

Same problem here. Installed upgrade from C5 and found the same problem. grrrrr… C5 stll works fine. I did have to downgrade to netframework 2.0 to install elicenser. I’m going to try to go back up to 4.0 netframework and see if that works!

Please let me know if it works. I know I won’t sleep until I get this sorted out.

nada…didn’t work. I also un-installed C6 and re-installed. Stumped. I’m going to sleep frustrated…

Does anyone else have any ideas why Cubase 6 won’t work for me?

Hey Rick, Did you upgrade with the grace period deal? Just looking for similarities with our installs. I’m running XP pro sp3, duo 4.2’s, the latest netframework. Plenty of ram.
When I started installing C6 a message popped up saying I needed netframework 2.0 or later. I clicked ok and the install continued. I already had netfw.4.0.
I had to download elicenser from Steinberg and during that install the same message popped up and the install stopped. So I downloaded netfw 2.0 from microsoft and installed. I went and installed elicenser again with no problem. Then I tried to launch C6 for the firs time and got the same error message that you got.
I went back to microsoft and downloaed netfw. 4.0 and installed. It actualy just repaired the version I already had.

I un-installed C6 and re-installed, bt still can not launch C6. :question:

1pm edit: I un-installed previous versions of netframework and repaired netframework 4.0. Re-installed C6 but still have the same issue. Really would like to know whats going on here!!! So far I have a very expensive shiney silver coaster!! lol

I did order the upgrade from C5. I never got a message to download the framethingy.

Hey Rick,
Follow these instructions from another user

hi jam

have you tried installing netframe 3.5 + sp1 and then install the latest elicencer , reboot and open c6 ,the main issues have been the net framework with xp but this is what ive found to be the minimum netframe that is stable ,for some reason uploading the net framework with out the service pack is leaving files out ,don’t no why but i had the issue loading c5 BUT if you load 3.5 and sp1 then the latest elicencer it should run sweet as a nut


If you have trouble, email me
I’ll tell you how to download the patches from microsoft!

just thought this would be of interest for you , its the code error you have been getting and this is the original email i recieved 2 days after c6 was released ;

As long as you’re on XP SP3 and .net framework 3.5 sp1. Now it isn’t officially supported that’s why I had to figure this out myself. And of course I cannot be held accountable for any failure that might occur, much like Steiny themselves. I could however be of assistance since now you can compare your troubled XP with mine, if you’re struggling with upgrading to C6, that is.

I was going to post this on first, but I am having difficulties with my password there, but since there is a Cubase thread here, I thought I might as well give you the scoop on this.

I had two instances of XP with a previous Cubase(4): one on the flipside of my MacBook XP SP3 and one on my AMD desktop. The big differences between those XP’s was as documented above. On the Mac XP it installed without issues. On the AMD desktop I got the 0xc0150002 error code. By googling a bit I started thinking there might be a file missing from .net framework or SP3. Since those were the most striking differences between these XPs I opted for upgrading the XP on the AMD desktop. Cubase 6 was already installed there. After upgrading it worked as advertised.

Thank you so much for trying to help. I will try this when I get home. Might not be easy since I dont put my DAW Online. I will email you if I have problems. Thanks man!

Just wondering if you were able to resolve and get C6 up and running yet.



As others have stated, Cubase 6 is not officially supported under Windows XP.

I had the same problem as you,with the same error code.

Make sure you are running Windows XP SP3 and NetFramework 3.0 or 3.5. It will not work under 2.0 or 4.0.

That’s what I had to do to get it working on my desktop and my laptop. Tried to install NetFramework 4.0 on my laptop and Cubase was not happy. Installed 3.5 and Cubase 6 works great. I have NetFramework 3.0 on my desktop and Cubase 6 works great there, too.

Thanks goes to jam… He helped me get up and running. By, downloading the .Net frameworks 3.5… YEAH!

btw… you don’t need previous versions of the .net framework on your system. You can run this to completely remove earlier versions. (You can choose exactly which versions to remove).