Cubase 6 with Automap 4, do they work together?

I use Cubase 6 on Windows 7 pc. Just about to purchase a Novation Impulse 61 and i thought id run Automap 4 past you guys and see if anyone has had any problems running it. Or of course to see if any of you have it up and running successfully and would even go so far as to recommend it?

I should just let you know that I’m working on this puzzle right now. So far, I’ve figured out some things and have gotten them to work like controlling Cubase is pretty seamless. Controlling some software is a nightmare however, specifically Omnisphere.

Yeah I use Omnisphere,… be grateful if you could post back to say how youve gotten on with it.

I’ve been a long time user of Novation Automap Pro … and love it! The problems with Spectrasonic products is that in their attempt to provide near total access to the internal parameters of their products, they have used an awkward and convoluted system that presents only a limited number of ‘named’ parameters to Automap … or any other controller, leaving the vast majority to require a combination of using ‘midi learn’ inside the Spectrasonic VSTi with some interaction with the controller, including Automap, to work correctly. I’ve given up on figuring it out, since the main parameters and standard CCs are availble with the controller.

This is not true with any other VST/ VSTi product I’ve tried. As soon as you understand that Automap simply ‘shakes hands’ with the list of parameters provided by the developer in the product, in the ORDER that the developer placed them on that list, you understand why initial ‘automapping’ seldom makes much sense. There is no General Midi equivalent standard for how these lists are ordered.

But! With Automap Pro is is so easy to reassign the parameter to different encoders, pots, sliders or buttons, depending what Novation automap enabled hardware you have, that it is far the easiest method of controller programming I’ve encountered. Of course, you can set your new mapping to ‘default’ for the next time you open that VST/ VSTi and you can create and save alternate mappings in the folder of your choice for use from time to time.

All that said, I’m disappointed in Automap 4.0. I was briefly a beta tester, but dropped out. I had some annoying ‘freeze on loading’ problems with Cubase 6 that are not really a big deal in a beta, but inconvenient to my work flow … and going through the endless checking of which VST/ VSTi I wanted to again ‘enable.’

The real issue for me was the change to the drop down parameter menu, which some might like. But the cost of it was the scalable GUI. I now found the text on the on screen GUI indecipherable (tiny small) with the fixed display size. I also disliked that they removed the little ‘Automap’ border frame which went around the plug-in GUI and had some handy, immediately available features. I happily, for the present, returned to the latest version of 3.0 … which I assume you could also do, if you chose to.

The two biggest shortcoming of the current Automap software … something complained about for the past several years and version updates … is the inability to insert a page in the template as you choose within a multipage template and the inability to copy paste a page or part of the controls on a page to another page, which would be very useful when you want, for an example, to dedicate the faders to common global parameters across each page and use the page for specific subfunctions.


Automap 4 beta was pretty buggy but Automap 4.2 works perfect here with Cubase 6 on win 7 64.

Hi jconstantine,
what device do you use with Automap 4.2. I’ve got ZeRo SL Mkii and it doesn’t work with 4.2 at all, I mean VST3.


I installed 4.2 following all the instructions provided by Novation…with no luck. It worked fine for one day and when I started up Cubase the following day, Cubase booted up without any of Automap’s 4.2 settings…it didn’t recognize AutoMap, configuration settings or any VST’s.

Had to roll back to 3.74. This works without any problems. Very disappointed with Novation! Their auto-installer is buggy.

I’m Windows 7 based on an HP I7 with 8 G ram.