Cubase 64bits + 32bits plugins = Nightmare?

Is this just happening to me?

If I open a project with a Cubase 64bits and it has a 32bit plugin in there, when I try to edit the plugin it just don’t work.

Then When I try to close cubase it gets frozen :confused:

I guess that you know that 32 bits plug-ins don’t work natively in a 64 bits host ; they have to be bridged to work, at the expense of a less stable setup but it more or less work. Cubase/64 has its own ‘VSTBridge’ to allows this and it works transparently, provided that the plug-in is compatible with it and the scanning paths (see the ‘Plug-ins information’ window in Cubase) are correctly set.

The problem is that it’s a hit or miss situation : the bundled bridge in Cubase is well known to fail with some plug-ins. It’s been a weakness for years, but the situation has improved one version after the other. Here, I have three bridged plug-ins with the bundled VSTBridge (2 VSTis and an Fx one) that are working without issue. What you should do, I think :

  1. Try to relaunch again Cubase after getting rid of the following files (in your preferences folder, i.e.: C:\Users<username>\AppData\Roaming\Steinberg\Cubase 6_64) :

Vst2xBlacklist Cubase.xml
Vst2xPlugins Cubase.xml
VstPlugInfo.xml

2) If the issue is still there, look at what’s inside the ‘Vst2xBlacklist Cubase.xml’. In it, are listed the plug-ins prone to make CUbase misbehave.

  1. Consider installing JBridge (http://jstuff.wordpress.com/jbridge/) which is known to work with almost every plug-in throwed at it.

Good luck…

I second cubic13’s suggestion: jBridge works MUCH BETTER than Cubase’s own VSTbridge. In order for jBridge to work correctly, however, you need do to the following in order to ensure you don’t run into any problem:

– Run jBridger as an administrator when you create the bridged plugins.

– Put the jbridged plugins in their own folder (possibly on the root of the c: drive) and not with all the other VST’s.

– Put the original 32-bit VST’s in another folder and don’t let Cubase access them or conflicts between jBridge and VSTbridge will happen, resulting in Cubase crashing. The original 32-bit plugins should be in a subfolder inside “Program Files (x86)”

– Always run Cubase as an administrator. Best way to not forget is to go in the application properties (right-click Cubase7.exe), click on the compatibility tab and check “run this program as an administrator.”

Thanks for your help guys!

I installed the jbridge, even when it shows some problems when add a couple of VSTs, seems to work kind of fine.

I will wait until the 7.0.2 update before purchase it, hopping that Steinberg did his job and fix this… (also yeap, I’m kind of low of money :cry: )

Other option that I’m thinking is just to install the 32bit version :confused: