Cubase 7.0.2 / Cubase Artist 7.0.2 announcement

Admittedly I kinda prefer a fixed layout but I can get used to it I guess and over time it will grow on me.

Having said that I don’t often change the size of windows, generally I use the window menu to select between them and I have only a single monitor.

It did strike me as a bit strange though how the mixer scrunches up but once I show only the screen elements I want and channel types it is actually quite nice to use.

Oke a lot of bugs are solved… Unfortunately stay on top still not works on the 2nd monitor, will this be fixed in the following update?

Hate to whine, but yet another sloppy release. What cracks me up most is the even the icon on Mac has weird artefacts (not sharp and none transparent background). How difficult is THAT to fix. Lol.

My setup is complicated, going back to kit from 1987, sorry only two monitors. Loyal Cubase user? I met David Nicholson (look him up) in 1989
who gave me a Cubase 1.0 disk for the Atari, so please, keep your patronising comments to yourself.

C7.0.2 is running beautifully here. Yes I read the forum comments (have done for some time). I’ve worked in software development (have you?) and I’m telling you, bugs and shit happens. They’re working on it. Don’t you think they know about the bugs? Fuck, how did Mozart manage? Those quills were man-eaters.

Now I’m going to make music, have fun. If Cubase doesn’t work for you, there’s plenty of alternatives. Some of those have bugs too.

looks like the shit is hitting the fan ! 7 years later you are now seeing the full integration of yamaha , my bet is yamaha have taken over writing code for cubase and that’s why the design and the 3 party look of the mixer is there ,it’s not a steinberg thing it’s a yamaha fuck up , do you really want software designed by a company that make PRS range of keyboards lol … this time i am personally staying on c7 as im not up for buying yamaha software so it the words of the dragons …IM OUT !

Whassup? What’s going on here? Why is everybody qqing? C7 is great and the 7.02 update has fixed loads of issues.

Hello

fully support this request :exclamation:


Cheers

It is an explanation, in fact, for the mixconsole, with its different design of cubase. However, it was easy to adapt. Perhaps Steinberg tests customer…

what planet you live? I cannot load my old project from 7.0.1, seems to be problems with some plugs? some connections? who know, I’ve to spend half day now to find the problem or back to 6.5.4? More problems than before, because if is all perfect for you means you dont know about music composition or production. Please dont be offended by that, it’s not my intention but C7 does not work as the promised and we payed a lot for updating from 6.5. This is not honest, not fair.

i had some issues from passing from 7.0.1 to 7.0.2.it drived me crazy all night,things like bad calour settings,no more knoobs in the mixer & some other issues.
So i went on the download center of steinberg ,and i downloaded the install core data for cubase 7.
i installed it on top of the cubase update 7.0.2.
And by magic,everything seems to be working perfectly.
i hope it helps some of you out there. :wink:

I’ve found a bug, the C7 7.0.2 does not load my 7.0.1 project under 64bit mode, all works when we are in 32bit. But swiching from 64 bit to 32 lost all new fantastic mixer configuration design did in 64bit mode. Graphical mixer problem under 32bitmode right side does not complete the graphics, looks like some will be after the master stereo out, look the picts. So now in 32bit mode I can load my old projects from 6.5.3. and 7.0.1 without crash.

Thanks Steinberg for the new incredible update.
mixer not finished.jpg

I don’t understand anything about music composition or production because my projects load fine? That’s a hell of a logic.

@Sub, me too, seems I’ve been playing air guitar for decades and did’nt know it…maybe I’m using ‘air Cubase’ now.

Sorry for those who are having problems. One thing I would say is, don’t use plugins below VST 2.4 although I’m using ‘SHEPPi Free Spatial Enhancer’ spacial plugin and that one is VST2.3 and is 32bit to boot, but seems to work fine so far.

Mauri.

Yeah, old plugins are probably the culprit here.
As said, I don’t have any issues with loading projects or stability in 7.02. But then all my plugins are 64bit and > VST 2.4. I did a plugins streamlining before first installing C7. Back then, I realised that I had tons of plugins that were actually doing more or less the same. For example, zillions of different compressors, although I mainly use RComp and PsP comps. So I got rid of old stuff and kept only original 64bit versions, mostly Waves, PsP and NI. No JBridge, no old VST versions. I haven’t experienced any stability problems, not with 7.0, 7.01 or 7.02.
Of course, when I open an old project that used to have an old plugin loaded, I have to load a corresponding Waves or PsP one instead and tweak a little bit. But this ain’t much of a problem.

Cheers.

the big problems seems to be under OSX 10.7 or 10.8 not windows… Im using C7 with Native instruments, PSP, Spectrasonics all updated to newest versions. No k software or plugs on my mac. So most of the windows users are happy, mac users still in big troubles.

Good way to check your plugins on a mac …

http://pluginupdate.com

It’s in beta still, but working pretty darn well. Misreports a few steinberg plugins for me, but get most versions right.

Good way to check your plugins on a mac …

http://pluginupdate.com

It’s in beta still, but working pretty darn well. Misreports a few steinberg plugins for me, but get most versions right.[/quote]


Thanks a lot for the info, finally someone is suggesting interesting things. So unfortunately all my plugs are already updated to 64bit versions and the problems are still there. I repeat not problems on 64bit with 6.5.4 only with C7. So why the plugs works fine with the old 64bit versions? We will see the solutions next 2 months when steinback will ask us other 100€ to update to 7.5.

@Jurij,

Steinberg does not charge for updates, only upgrades. The only time this has happened (iirc) was with C6.x to 6.5 and the update (voluntary!) included two Steinberg synths which made it a bit more than a normal update.
There was a free update 6.x to 6.0.7 which included all the fixes 6.5 has, but not the synths.

I don’t know why you keep saying Steinberg charges for updates when it is not true.

Mauri.

it’s a point of view mauri, I brought all versions, 6 was buggy so we wait 7 releases for a stable version, 6.5 promised to solve other problems and yes new features, but 6.5.4 to have a semi stable versions, with a prerelease, they promise new features on 7, but after 2 months the software it’s hardly unstable under osx version. I’m happy you are satisfied, but since last year we worked hoping not crash during the job waiting updates after updates, and payin in the meantime 2 times from 6 to 7. It’s not a good policy in my humble opinion. Nuendo it’s not out yet, you know why? Just wait we finish the beta testing under cubase.

it’s only a point of view. Im happy to use cubase, i love it, i told that many times in the forum, but im feeling frustrated beta tester as other users under OSX. Now im back to 6.5.4 because it works much better than C7 in the same machine with same plugs, and in 32bit mode because 64bit make a lot of crashes as I reported with pictures. CPU sparks and performances issues. Next time I will buy the new “upgrade” of course but after 6 months or more from the official release.

We want respect and “sorry” somethimes not always.

Not true! Versions 6.0 thru 6.0.7 screwed up the lane comping big style for audio and MIDI. The select (arrow) tool became a comping tool, whether you liked it or not. We had to pay the upgrade fee to have this fixed in 6.5.