Cubase 7.01 - tempo issues

I’m having a problem with an specific project.

I can’t remember the steps, but I tried to use the tempo detection a few times and then deleted what it proposed. Then I changed back all my tracks to musical mode, but the tempo is a little mess up yet! I can control if the midi plays faster or slower, but it doesn’t match the metronome! Visually, things are out of the grid also!

Is there anyway to reset all tempo configurations in Cubase? I think this would help.

My project only have one stereo reference audio track and a lot of midi and vstis.

Core i7 2600
16 GB of RAM
SSD OCZ Revodrive (system)
WD Black Caviar 2 TB (samples)
WD Black Caviar 1 TB (audio)
RME Babyface
Windows 7 (64 bits)


Unless you can warp the tempo of the audio in some way, you are stuck with the tempo the audio plays at.

It sounds like you adjusted the tempo between times that you switched the midi tracks between musical and linear mode.

Unless you have a backup you would have to put things right manually, I’m afraid.


Thanks for the reply. Actually I don’t want to change the audio, just the midi.

Thanks! I could export the midi and start a new project, but all my routing and instrument tracks are already set up in this project. That would be very laborious, if I had the chance to fix it in this project, I would prefer.

Tempo detection is really for audio, since if you change the tempo for MIDI parts; being performance information a song will speed up and slow down depending on the lines drawn in the tempo track unless you have a fixed tempo.

Yes! I tried to use the audio track as a reference (tempo detection) to recreate that with midi. But as the original audio performance was not very good, I changed my mind and deleted all the tempo changes that was printed in the tempo track. But now my midi and my metronome is not in sync anymore, even though I recorded with the click, with a fixed tempo.

Are all the midi tracks in sync with each other?

Yes! And when I change the tempo, either in tempo track or in fixed tempo mode, the tracks actually play slower or faster, but never in sync with the metronome nor visually in the grid.

In that case if you can figure out at which tempo the midi tracks are now playing you can (I believe)

  • set all midi tracks to time-linear
  • set the Cubase tempo to the tracks’ actual tempo
  • toggle them back to musical timebase

Thanks, I’ll try that!

But is this a known issue in Cubase 7.01?

I can’t remember having this trouble with version 6.5.

There is no issue, it is just how the sequencer functions.

I’m sorry, but I think my posts are not clear so.

What I did:

1-) Recorded midi to a fixed tempo.
2-) Tried to use beat detection a lot of times in an audio reference track.
3-) Deleted all the tempo beat detection printed to the tempo track.
4-) Changed all tracks back to musical mode.

After this is steps, my metronome is not in sync with the midi anymore. And the notes visually are not in the grid anymore.

Fair enough, but for any potential change, it is advisable to make a backup beforehand.

As to your problem, what was the original (default) tempo?


Around 78bpm.

You’re posts were clear, what probably happened was what I said earlier.