Cubase 7.5 Track Arm problem

Hey everyone,

I’m having a major problem with Cubase 7.5. Here’s whats happening:

I do mostly live concert tracking. Hence I often have only one chance to capture all my necessary channels at once. With the project open (lets say it’s 10 tracks for an example) I arm all tracks and its business as usual…no problem there. Where I run into an issue is that if I select a track while it’s armed, as soon as I select any of the other 9 tracks the one I have just clicked away from instantly stops being record enabled. This happens whether I am actually recording or not. It has caused me to lose information and really lose the ability to monitor/create a reference mix since I have to treat Cubase as a tape machine. Any project I have open is doing the same thing and it’s driving me nuts because I can’t trust the program to capture what I think it’s capturing unless I don’t touch the machine during record. Hopefully y’all can help me shed some light on the subject, since I can’t believe there is no way to disable this “feature”.

Any thoughts?



Yes it is a feature, or prefrence. Check off “Enable Record on Selected Audio Track” in preferences.

Thanks! I thought I’d tried that, maybe I hadn’t hit Apply. Worked perfectly.