Cubase 7 and Oxygen 25 No sound from the Oxygen

Hi everyone. OK so i have cubase 7 now and i got the Oxygen 25. I used the directlink and moved it to the cubase 7 component folder.
I also did the device setup clicked on the + sign and added the Oxygen 25.
The problem is that there is no sound coming out when i try and play the Oxygen keyboard but if i go to the VST and use the piano roll i do hear the sound.
Tried to find a solution online but nothing.
I have Presonus studio one v2 also and its playing great with no setup needed.
Any help will be great See the attachment for my device setup. Maybe i need to press on a preset number in the Oxygen or something.
Thank You
device-setup.jpg

Please anyone have any suggestions for me? or used Oxygen with Cubase. i can see the signal working when i press the keys but no sound coming out. But when i press on the keys in the actual VST i can hear it.

What is the input for your track set to? Monitor button enabled for the track?

What VSTi are you trying it with?

MIDI or Instrument track?

I’m on 6.5.3, but I just got the Oxygen61 and had a similar issue. Let me guess - the transport controls (play/stop/etc) work but the keys (ie, sound) doesn’t?

The “fix”, as I stumbled upon it in 6.5.3, was this:
The instructions that came with the M-Audio Cubase DirectLink driver seemed to be not entirely correct. It said something to the effect of “go into Devices/Device Setup and add the Oxygen(61 or 25)”. So far so good, but then it says something about specifying the In and Out “ports” as “Oxygen ##” and “Oxygen ##”. DON’T DO THIS. On my system, doing this essentially made it so that only the controls portion of the device (transport/cc controls, etc) worked, but not the actual keyboard notes. If I removed the Oxygen remote control device in Device Setup, then the keys would work but no transport control. I finally tried NOT specifying the ports as described in the “intructions” and VOILA! both the keys and the controls now work.

Hopefully this will work for you in v7 too.

ell i tries using all midi inputs and only the Oxygen input and the monitor button was enabled yes and tried without.
i tries few VSTS with it and used an instrument or MIDI tracks…
Never happened to me before. With preosnus or Reason its just plug and play in few sec.

Ill try but i did the same before and nothing ill play with it more…

Sorry, I was away from my computer at the time but I rechecked last night and the actual settings in 6.5.3 are:

Midi Inputs = All MIDI Inputs
Midi Outputs = Not Connected

Which is to say, DON’T select “Oxygen##” as the MIDI inputs under the remote control device in device setup. Not sure why that would be.

I’m still having some issues myself as far as getting ALL the controls to work (only 3 of the 9 sliders seem to work on the mixer, etc), but the knobs are assignable and the transport controls work. And, of course, it makes MIDI notes, which would be the main thing.

Aaah, and now I can see your screenshot - be sure to notice the settings I’m talking about are under the “Oxygen##” under “Remote Control Devices” on that screen, not under “MIDI”…

Curious to know if it behaves the same as in 6.5.3.

Rejoice, I got the other sliders to work. Apparently once the track is created you need to push them all the way to the max position to get them to “grab ahold” of the sliders in the mixer. I guess this makes sense, that way they both start at the same relative position. Still, took some noodling as I figured they would start at 0 or the bottom rather than the top.

Thanks for the input. Ill check it tomorrow