Cubase 7 audiotrack tempofit?

Hi guys!

I’ve recently switched from Logic pro 9 to Ableton and now I’m on Cubase, and loving it!

What I do find difficult inside of Cubase 7 though, is the audiowarp or audio-tempo-fitting.

Basically what I want to do is to have a FIXED tempo of lets say 130 or 150 bpm (really important that the tempo does NOT change over time, it needs to stay exactly the same, since I’m making music for DJs on the clubs such as house, trance , electronic music in general etc)

I haven’t found a single tutorial on how to do this WITHOUT having a tempotrack? I just want the audio to be flexed/fixed/stretched to the fixed tempo of my project. I’ve tried to switch on audiowarp and I’ve tried to manually nudge the audiotrack to see if it fits with the metronome, and I get quite close, but it’s still not spot on.

Could ANYONE please lighten my knowledgebase of cubase up with this? I’d really appreciate the help!

Much love! Thanks!

anyone?

This is probably whats making me insecure about cubase, if I can resolve this issue, It’d be a HUGE help, honestly. Please help, anyone?

I make the same kind of music and I can’t even remember ever using the tempo track… I think the tempo track is more for the guys recording live acoustic drums.

First of all, are you talking about importing full tracks and getting them synced with the project tempo or are you talking about importing loops?

Regarding Loops:
Almost every time I drag a loop in from Mediabay it automatically syncs/warps it to the track tempo. The rare times it doesn’t I just select the loop in the project window, hit “crl - f” to bring it up in the pool, then I make sure the “musical mode” box is checked and then type in the correct bpm. Also if you want to add swing to the audio loop you can do that by using the Quantize Panel.

Regarding importing tracks for DJ Mixes:

  • I just drag n drop the track in from iTunes
  • Usually there is a second or two of silence at the beginning of the track so I zoom in and cut away that silence so it starts exactly on the first beat.
  • Then while the track is selected click “ctr - f” to bring it up in the pool and check the “musical mode” box.
  • Next I find the bpm. There are many ways to do this. Usually I just try typing in different bpms in the pool till I find the right one but I’m sure there are easier and faster ways of doing this…

Hi Stealth!

cheers alot for this answer!

I’m thinking about acapellas and such, I’m about to do some remixes, but just can get the acapellas to fit the metronome.

But also whole tracks as you said, to do mixtapes and stuff.

Is there any other way to get those loops to fit? they fit 90% of the time if dragged from the mediabay as you say, but sometimes they doesn’t… what do I do then?

Acapellas with a different tempo is what I mean though, I’d really get the hang of that.

Again, thanks for answer!

First make sure the pool version of the file is set to musical mode. Set an elastique mode. If you know the source bpm, set it in the pool. Go to the project. Use one of the alternate “sizing” option of the selection tool (select tool has 3 modes). You should be able to size those pesky files that don’t cooperate this way.

Being able to freewarp in the arrange page has been a big request for quit awhile. Hopefully, the concept will be allowed at some point. However, one thing you can do if the beat isn’t aligning well even after the above steps … tab to transient, cut then use the sizing tool, tab to transient … repeat. This avoids having to go into the editor and muck about with the freewarp, which I have a terrible time with.

If I get what you are trying to do, this is my procedure. If I have a project that’s 130 bpm and i load a song that’s lets say 126 or whatever. I will

  1. Cut a 4 or 8 bar loop from the song. (make sure you cut a perfect loop)
  2. Place it at bar 1 beat 1
  3. Hit the number 1 on your keyboard until you see the little clock near your mouse cursor
  4. Grabthe loop at the bottom right corner and stretch or shorten the loop to fit in the first 8 bars of the project.

Then you can just stretch out the loop accross the project and it should be in tempo if you move it around snapped to the grid. Hope that helps.

Thx, but what I mean is that when I have musical mode on, it’s REALLY REALLY close to be spot on the beat, but it starts to get out of sync as you go further into the song or the acapella. So what I basically need is just to adjust it a tiny tiny little bit. Cheers

Which is the scissors/size method I described.

Well, when I do like that, I end up with a perfect 4 or 8 bar loop. But when I need to stretch it, WHERE do I stretch it to? what bar that is… since I already have a perfect 4 or 8 bar loop (which is out of sync), do I stretch it to the 9 on the line up there? or where?

I get the point, but I don’t really get how I should do it in practice.

Thanks°

So cut at the transient. Turn off snap. Set the Select tool to to one of the stretchy modes (it will depend on the kind of stretchy you need to do). You want to move the two parts toward the beat. You may need to make additional cuts on earlier and later transients just so you are compressing/stretching smaller sections. Once you have aligned the 2 segments, glue them together again.

This is only good if there are a handful of fixes to be done. If there are lot, you just have to gut it out and go into the editor to play with freewarp. I found it better to chop up the audio and use freewarp on smaller pieces. It is a piece of shit compared to using Reaper or Protools. But, you can get the job done.

OK yeah acapellas are sometimes a little trickier. What I do with an acapella that I’m having trouble syncing/warping is load up the original track the acapella came from. I just sync/warp the original track (using the method I described above), then I’ll put the acapella in the track above the original track (with its “musical mode” box checked and bpm set to same as the original track in the pool), temporarily turn off the snap and line it up with the original track underneath. Then just delete the original track and you have your acapella all ready to go. :slight_smile:

Time Warp Tool, p. 619 of the manual.

completely useless for this problem

If it’s slowly going out towards the end of the acapella, then it’s simply a matter of tempo. You probably have the tempo of the file set incorrectly. Here is how I do it;

  1. Drag and drop your acapella into your project, can be from desktop, audio bay or pool doesn’t matter. Make sure musical mode is OFF.
  2. Find the first down beat of the acapella and line it up with the start of the bar somewhere in the project (preferably out far on the right where nothing else is playing.
  3. Press ‘c’ to turn on the metronome.
  4. Now this step is where the skill comes in. Play the acapella from the first down beat and listen closely to the tempo of the singing and the click track, you will need to change the project temp to match the tempo of the acappella (don’t worry we will change it back) You may need a few goes to get it right.
  5. When you get the tempo right, double click the audio segment in the editor and where it says tempo at the top of the window change the value to match what your project is now set to. Now turn ON musical mode.
  6. Your acapella is now locked to your tempo, so change your project tempo back to what it should be.

This seem rather complicated but can be done very quickly when you get the hang of is. There is also a shortcut using the mouse wheel to change the tempo up and down easily, but I’ll let you figure that one out…

And don’t worry I feel your pain, I also write techno/dance stuff and 99% of the info out there relates to mixing bands and drums, but we have a machine for that!.. :smiley:

It’s insane… Cubase is the ONLY program I still struggle with this. In Logic it’s sooooo easy to just activate flexmode at its original tempo and then just increase the tempo of the project. In cubase, no matter how hard I try - it’s sooooo annoying, I don’t know what to do to fix this. I spent literally 2 hours trying to figure this out now… and I really can’t make the acapella fit the tempo of the project when speeded up … eventhough I found the offbeat etc. I followed all these instructions without success still… is it REALLY that hard? HELP?!

Actually it´s quite simple - You create a valid tempo map of the audio (How this is done depends on the audio file itself, and can be done automatically, or manually and everything in between - again depends on the audio file).
Once that is done, set the file to musical mode, and it will follow any tempo changes.
If the tempo runs out of sync versus the end of the track, your tempo mapping is not correct and needs to be adjusted manually - for example by adjusting the warp tabs.

I found a way of doing this IF you know the tempo of the sample.

That was simply by right clicking on the track without musical mode on then > process > time stretch to the new tempo.

But if the tempo is unknown, I’m really clueless… eventhough you describe it here, I can’t seem to get my head around it. Mind providing any video or example of how to do this? I’m insterested in learning how to do it! Because for me it’s extremely hard inside of Cubase…