Cubase 7 + Halion 5

Hi guys,

I’m bit lost here. I’m trying to find the optimal setup for running Cubase 7 with Halion 5.

My computer specs
Windows 7
i7 2700k 4 cores (8 virtual) 3.5ghz
16gigs of ram
RME babyface with latest drivers.

So I’m getting loads of real time peaks when I have the multi processing turned on cubase (having multi processing turned on in Halion doesen’t seem to effect much on the real time peak meter) also I’m getting crackles and pops.

To my understanding for the Cubase 7 to use computers full power, I should have the Multi processing turned on.

So I’m wondering what’s the “correct” setting? Having it turned on at Cubase or Halion? What’s the best way to squeeze most juice out from my computer?

Using Latencymon program didn’t reveal any issues with the computer itself.

Thank you in advance and sorry for my English!


I have not experienced any performance issues between HALion 5 and Cubase. My computer has a 6-Core CPU and 32 Gb of ram so I have a bit more headroom to play with. But your system should be fine, you have plenty of CPU and Memory to work with. I use to run an i5 with 8 GB ram and rarely ran into issues unless I was working with a huge project.

It may be your ASIO settings, what is your Sample Rate and Buffer setting? Running a low-low buffer size would be and issue if you have lots of things going on in your Projects (ex: many audio tracks with heavy plugins turned on). The RME Babyface is a nice card so you have options there. If your mostly working with VST’s and not direct recording instruments you can get a way with a larger buffer setting and higher latency. There are a lot of opinions out there on proper ASIO settings so see what you can find on the subject and try out a few different setups. My settings are just what works for me, I’m by no means a Pro.

It’s also good to use multiple disk drives (SSDs if possible) to cut down on the I/O traffic. Again, if your ASIO Buffer Setting is too low your computer will need to do extra I/O to keep up. Doing this on one Hard Drive is a performance drain. I have three drives, OS and Programs (like Cubase, HALion) installed on one, another for my Projects and the third drive has Samples, Sounds, Presets, etc…

Below is a list of my settings, many are just defaults.

ASIO Soundcard Settings:

Sample Rate = 44.1 kHz (I try 96 kHz every once in a while but always fall back to 44.1)
Buffer size = 96 samples (I bounce back and forth here, if my project has more External Instrument Direct Recording to audio I’ll drop it to 64 samples)

In Cubase Project Setup:

Bit Resolution = 24

In Cubase - Device Setup:

Audio Priority = Boost
Multi-Processing = On
ASIO-Gaurd = Off
Activate Steinberg Power Scheme = Off (note: I have this off because I made several similar tweaks to my computer to optimize it for DAW usage, you can have this on)

In HALion under the Options Tab:

Max Voices = 128
Max CPU = 90
Voice Fadeout = 5ms
MultiCore = OFF (important, if you have Multi Core turned on in Cubase you do not need it turned on in HALion)
Disk vs Ram balance, = One tick over to the Ram side
Max Preload = 1280 (I’ve bumped this up/down and have not had any noticeable results)

For Sample based sounds I tend to run at normal settings until I have a track set, then I crank it up to Best or Extreme (under Zone->Sample Osc) when bouncing to an Audio track/file.

Not positive if this effects performance at all so it may or may not help you but I also try to keep my HALion VST Rack instances to 8 channels/instruments Max, 4 if possible. This is just my preference to help workflow and organization. Depending on what you are trying to accomplish will dictate this, if you work with complex Multi’s or orchestral sounds you’ll want to make use of as many channels as possible.

Thank you for your comment. I really appreciate you taking time to answer.

I use seperate hard drives (one for Win and programs, one for samples and one for projects). The project where I had this problem (it’s actually template project) is where I have on instance of batter 4 and then five halion instances with nothing but sine wave loaded, and for reason or another I got crackles and pops. I had the buffer set pretty low (96 or 64), but since there wasn’t nothing really processor intensive I thought it should be ok. But it wasn’t, so I’m wondering if there is something else that I just don’t see.

Anyways, I’ll try out your setting. I pretty much used similiar settings, but let’s see if there is difference.

Thank you once more!

Ok, so I did some testing, and the culprit seems to be Cubases multi processing setting. When it’s turned on, I get weird clicks and pops, and when it’s off I don’t have problems. That’s weird. Shouldn’t it work the other way around?

I’ve never had an issue with Cubase 7’s multiprocessor feature, but ASIOGuard gives me guaranteed DPC spikes every few seconds, resulting in audible pops during playback. (My primary interface is an RME Fireface UFX.) I was really scared the first day I fired up Cubase 7 to work on a new project. Took me a day to figure out what was happening.

Make sure you’ve got ASIOguard disabled before you do anything else. It also seems to be enabled on a per-interface basis; if you plug in a different interface you’ll have to re-disable ASIOGuard the first time you use it.

If you’re using ASIOguard, remember to enable it per vst as well(go to that vst properties page thing, look at one of the right-hand side columns). ASIO works well for me here - but only after I manually enabled it for all VST’s I use. This could be explained more in the manual/during set-up.

Good advice. Thank you. I’ll check these advices out and let you know how things worked.

I’ve heard that the graphic card can sometimes be the problem.
Do you have the newest drivers?

AndrasFL- I haven’t updated my graphic card driver for a while. I’ll try that, thank you!

So this is bit weird. I couldn’t really locate what’s the issue, but I’m getting better results now that I enabled the asio guard individually for plugins (thank you vespesian), moved my Cubase 7 and Halion 5 content to another drive, and enabled the MMCOS setting on RME card.

The weird thing is that the template project that caused me to search for solution this problem is still causing peaks. If I create another project with same setting there isn’t any problem, but only with the template.

Anyways, generally I’m getting better results now, so thank you all for your advices.