Cubase 8.0.20 - Detect/Strip Silence + VariAudio + Undo bug.

Hi There.

I did a detect silence on all tracks, breaking the stems provided to me in to nice clean regions, as I usually do.

I then started to use VariAudio on one of the tracks, but then went do undo my VariAudio edits.

Upon Undo’ing, it undid my “detect and strip silence”, while leaving the new regions this same “detect and strip silence” had created. I have attached a photo for example. How would it undo the strip silence yet still keep the regions created as a result?

To make it more bizarre, it must have skipped back many undo steps to bring back all the stripped silence.

I have never seen this in previous versions, must be some kind of bug.

Can anyone recreate this?
Screen Shot 2015-06-23 at 5.39.35 PM.png

Here is what I did:

  1. Import audio from a different project (3 vocal tracks)
  2. Detect silence so it made regions out of the long audio file
  3. Opened all 3 vocal tracks up in Sample editor: Vari Audio - pitch & warp
  4. Made pitch corrections to all 3 vocal tracks.
  5. Hit undo

I tried the above steps again and this time everything was able to be undone correctly. I’ve tried it a few times now, both undoing while in the sample editor, and undoing while in the project window, and I’m not able to reproduce your specific issue premediesel. Is there a step I’m missing?