Cubase 8.0.40 automatically moves sliced audio to "double time"

Good Day Everyone,
I’m having a headache with slicing a two channel conga track. The High Conga and the Lower Conga (Tumbadora). I’ve imported two tracks as the conga player was using two mics (one for each drum obviously). I then created a folder track so that all editing affects both tracks simutaneously.
When creating Hitpoints, I went through the entire track and made sure all markers were placed with the best possible precision. I then selected “Create Slices” under the “Hitpoints” tab and all of a sudden, the sliced audio became compressed and shifted and they now sound double-timed. I turned off the “Iterative Quantize” option in the Quantize Panel and turned off “Auto Quantize” in the MIDI Cycle Record Mode window , but it makes no difference.
Any help would be greatly appreciated! :pray: