Cubase 8.5.0 + Win10_64 VST periodic spike

I’ve encountered this since upgrading to Windows 10.
I have a blank, empty project open. No VST plugins or instruments.

Watching the VST performance window, I see a VST clip on both peak and average meters every 150 or 300 seconds. It appears pretty regular. The effect when in use is a dropout in both playback and recording/rendering.
Looks like something is waking up periodically and pegging the VST engine. Disc remains at 0.

Windows 10 64 bit: 1511 10586.36
Cubase 8.5.0 Build 69 (64 bit)
16GB RAM, i7-4771 3.5GHz
UA Apollo hardware over FW800.
All operated OK in Win7-64 prior to update.


Further notes to this after some more testing.
With the Nektar Panorama P4 control keyboard plugged in (USB), the VST spikes occur every 150 or 300 seconds (as above).
When it is unplugged the VST spikes occur approximately at 12 minute intervals.
No apparent network or disc activity at the time of the VST spike occurring.

Also checked with the UA Apollo disconnected and confirmed results are the same (ie not UA interface drivers).

This happens to me as well on Win 8.1 64 bit - was NOT happening with Cubase 8.03 - interesting to note that even in some tutorial videos on YouTube one can plainly see the spike peak (red bar) on the transport!

As far as I can tell it is not related to any particular plugin or instrument. I have had it happen even when starting up new (empty) projects.

I did not notice it happening with Cubase 8.5 under Windows 7-64, even when using the Panorama P4 Keyboard. It is only since the OS upgrade that it started happening.

Unfortunately there are lots of new settings in new places I have yet to explore in this OS and see if it has any effect. It is clearly observable and repeatable on the system here. The Nektar P4 just increases the frequency of the spikes to 2.5 minutes instead of 12, however I doubt it has anything to do with the actual cause of the problem.

A new machine, Skylake with 16GB, using different audio hardware and drivers (MOTU 896). Brand new install of Win10-64 and Cubase 8.5.

Open Cubase 8.5, no project.
Open VST Performance
Watch and wait. A VST spike occurs usually within 15 minutes, boith average and peak VST. No disc activity.

I too experience CPU skipes and overall more hit on the CPU, not sure if its windows 10 or cubase 8.5 though, as I upgraded both at the same time…

The problem is still present after the Win 10 cumulative update today (Jan 13th 2016).

I can confirm that this also happens for Cubase 8.0.30 as well.

Suggestion: Check to see if Microsoft drivers have replaced any of your ethernet or other motherboard supplied drivers. I recently checked this on my dual boot system and discovered this had occurred on the system exhibiting spikes. Replaced the drivers with the motherboard supplied ones and things are better (though 8.5 is not as performant as Cubase 7 or 8, no spikes though means it works well for my purposes).

Yes, the MS drivers appear to have replaced the Network and SATA drivers. I downloaded the latest Win10 chipset and peripheral drivers from Gigabyte and installed them. Can confirm the OS is now running with the Intel drivers.

Unfortunately it has not changed anything. The VST dropouts still occur on a regular basis.

Another test, this time using Wavelab (8.5) to perform some mastering tasks using a rack load of VST’s in the master section. No sign of any VST spikes or dropouts.
Back to Cubase and the spikes are present.
Looks like a Win10/Cubase problem.

Do the occasional spikes also occur when the Asio Guard is disabled? Myself I’m getting some rare spikes when it’s enabled (Win10 bootcamp & Cubase 64), so I’ve disabled it. The ASIO performance in general didn’t change for me after the disable

I am experiencing this as well. Running Window 10 Cubase Pro 8.5. For my system, it seems to be related to Windows Defender Real-Time Protection. I disabled it, and Windows 10 keeps turning it back on. When I shut it off, the spikes go away.

Win 10 pro - 8.5 & 8.03 spikes on an empty project! Nothing is loaded but the empty project
and i have spikes and system overloads every 30-60 seconds.

on my machine i’m working too with reaper, studio one and protools. they are flawlessy working, so my machine is properly configured. latencymom is very good on my machine.

only cubase behaves with spikes and system overloads on an empty project.

the things even get worser when loading for example sonarworks headphone plugin in the control room…every 5-10 sec
spikes and system overloads. same empty project on reaper 5.11 with sonarworks headphone and mathaudio room eq loaded for example, stays rock solid on 1,8-2% cpu - no spikes at all. the same with studio one and protools.
rock solid and no spikes at all. seems a very specific cubase problem

I was wrong…Defender was only part of the problem. It is my network card that is the real trouble. I downloaded the latest driver from ASUS, and it matched what was already installed. If I disable the network card, I have no spikes as all…even running my RME RayDAT at 32 samples, with Steinberg Grand 3 piano and Vienna Symphonic Library string VST running. Not sure who is at fault here…Windows 10, Asus/Intel, or Steinberg? If I run my DAW in isolation with all the offending Windows stuff turned off, Cubase is smooth running. Good to know that I can get it solid, but will be a hurdle if I want to use VEPro again, as that requires the network card drivers to be running.

I can confirm that the problem remains after the last Win10 update (10586.71) on all 3 machines with different hardware and different drivers.
This problem is not related to the hardware or any specific OEM driver set. It appears to hapopen with Cubase only.

Finally discovered that Asio Guard was causing the dropouts. This is not present in Wavelab or other VST hosts, hence the spikes only appearing in Cubase. Currently we have run one workstation that was having VST spike problems for a day without Asio Guard enabled and no problems have been reported under normal use.
Asio Guard was set to Medium, probably the installed default.

It was not causing any problems with Win7 and Cubase, so I suspect there are some problems with Asio Guard and Win10 that cause VST spikes periodically.

However, even with Asio Guard off, there is still a lot more VST activity (on the VST performance meter) than is expected normally. Maybe there is still an underlying problem that is more obvious when Asio Guard is switched on.

I thought I would share what i found with respect to my LAN driver issues I mentioned earlier. My Asus motherboard has and integrated network adapter Intel 82579V. I went to Intel’s website, rather than ASUS, and found a newer driver for Windows 10. Installing this totally solved my dropout/spikes in Cubase 8.5.

Drivers are very picky for audio. So many variables to hammer out. I think each person simply must tune their system to stabilize the combinations of hardware drivers with OS and DAW. It is time consuming and frustrating, but really the only way to solve the issues on your particular system.

Spikes are still there with the recent 8.5.10 Cubase update, although the audible problems are mitigated by turning asio-guard off.
I did notice that when changing the routing of a track (eg from “Stereo Out” to a group bus), the VST performance meter slams into red. Maybe that’s a clue.

There definitely are some issues posst the 8.5 update, even more on the 8.5.10 update.
It started crashing and having issues left and right.