Cubase 8.5 and Mavericks OSX 10.9 Compatible?

I’m on OS X 10.9 Mavericks. Cubase 8 works no problem but looking at 8.5 requirements, it says 10.10, 10.11. I’m assuming this means I have to upgrade to El Capitan. Is there any Mavericks users who have tried using 8.5 on their systems?