Cubase 8.5 Registration Problem

Hi,

I’ve been using my Cubase 8.5 for over a year for something.

But yesterday this message to choose ASIO drives popped up while Cubase was loading and once it opened to the landing page or whatever I realized that it was somehow default mode. After clicking that screen off I got another pop-up telling me to register the product. Clicked ‘already registered’ but then nothing worked. Tried everything to solved the problem with no luck, so just went on to open Cubase 9 (set up for a few months, not really used it cause I had problems recording audio), which worked fine.

Today I tried to open 8.5 again, the same thing happened so I just hit the ‘Register Product’ button, went to the online page, took my code out from my 8.5 box, put it in to newly do the registering. Message says my ‘Cubase 9’ is registered.

My 8.5 still doesn’t work.

What do I do?

(I’m not using 9 cause of the recording malfunction and some of my vsti seems to be more heavy in it)

Hi,

Could you be more specific what does “nothing worked” means exactly? And what does “Tried everything” means, please?