Cubase 8.5pro Key editor white screen

Since updating to 8.5 everytime I try and open the key editor by double clicking on a midi part I am getting a white screen and have to ctrl-alt-del to task manager to quit Cubase

This is not happening in 8.0.30with the same songs, I have also tried opening and re saving in 8.5 but it is the same. I can’t use the key editor without a complete Cubase crash.

I will try some other arrangements when I can.


I would expect, trashing of Preferences would help. But it would be nice to know, why they get corrupted.

Hi Martin, I tried that but it did not work. I ended up doing a complete format and clean install of Win10 and Cubase 8.5 which has worked fine. I was ready for a clean install anyway and when I get all my VSTi’s and other software installed I will make a SSD image for future reinstall if anything goes wrong later on.

Didn’t find out why the white screen crash in key editor but I am happy it is working now.

i have the same issue but i am not planning a format c:\ Any ideas…
When i first updated form 8 to 8.5 everything worked fine for me (win10 64bit). Than, at some point in history of december, i got the same error as “Sundayforsammy”

Any hints for me…
Thanks and merry christmas everyone


Could you try the Safe Start Mode and Remove the Preferences for this one start and tes it, please?

I just did it, no difference :frowning:

PS: Didn’t know there was something like this mode…


You have 3 displays, right? Is it the same when you open the KeyEditor on any display?

Hi Martin,
no, i have 2 displays, and yes, it makes no difference :frowning:

[SOLVED] After searching the whole evening I found an old reply from Chris Dobbs - Steinberg US Support which helped:

Re Cubase 7.5 freezes when trying to edit midi parts
Postby Chris Dobbs » Wed May 07, 2014 352 pm

I would suggest clearing your App Data to give 7.5 a fresh start

First, please shut down Cubase. Then go to the Start menu, All Programs, Cubase 7.5, Cubase 7.5 User Settings Data Folder. In the top address bar, you should see “App Data (roaming) Steinberg” Click on Steinberg at the top. This will put you in the Steinberg app data folder. Trash any Cubase or Nuendo folders that you see there. This will trash your key commands, preferences, sound card settings, etc. Hopefully this will also should clear up the problem you are having. Restart Cubase. You will need to reset your audio outputs (Devices, Device Setup, VST Audio System).

If the problem persists, are you running in 32 bit or 64 bit
Chris Dobbs
Application Specialist
Steinberg US Support

Yeehaw! That did the trick! Thank you!

i really tried a lot of different approaches, even tried killing every reference of 8.5 in the registry.
I thought i had something to do with some .NET framework but win10 ist resistant in updating it.
Whats also strange is, that this issue was only happening in 8.5 and 64bit, the 32bit installation (which i also tried) was working fine, also every previous version on my pc (in fact i only hat 8.0 75bit on it)

thanks again,