Cubase 8 and EuCon


Win 7 Pro 64 bit. i7 4930, Babyface, C8 Pro 8.0.0, EuCon 3.2.1


The Avid Artist Mix connects via EuCon fine in Win 8 Pro, but autobanking no longer works.


Tried resetting, removing and re-inserting, searching C drive for every reference to Cubase7.xml and checking to see if Cubase8.xml was present, and in every case (5 of them) Cubase8.xml was already there. Autobank is enabled in EuCon settings, C7, C 7.5, PT10, PT11 all working fine.

Auto-banking working fine here!

I would try trashing the preferences folder… make sure you temporarily relocate any previous versions of Cubase Preferences folders before you let Cubase Pro 8 rebuild its preference folder… so it won’t try to import any settings from the previous versions. I just temporarily put mine on the desktop, and then put them back when I’m done!

In Windows these folders are located at: C\Users*User*\AppData\Roaming\Steinberg\Cubase 8.


Good idea, will try that later today - thanks.

Hi there!

I would like to update to 8, but i have to know if everything works fine with eucon, and if my mappings are portable to 8. And are there some changes in general? It would be really nice if there is an uptdate for the adapter, too :sunglasses:

Cheers ,Tomess

This thread has some info in it - - I’m going to try trashing prefs later today / tomorrow to see if it fixes my autobanking problem.

I had a problem with eucon here when I first loaded the new version. it did not see any of my settings in the Artist Control but the faders worked and you could build new preferences, soft keys ect. I finally figured it out that there where no Cubase 8 xml. file. Here is a screenshot of the path. When i first got to this folder I only had files for Cubase 6 and 7. I copied and pasted the most recent version. Then renamed it (Cubase8) just as you see it. A restart and it worked just like it should. Hope you have the same luck as me.

PS sorry just noticed you are on PC. not sure what your path will be but it may be that the file was not in the installer mac. or PC.

Huh - disabled all preferences (holding shift / cntrl / alt), created a brand new project and added EuCon fresh, and still no banking. Weird. Perhaps it really is a Windows 7 vs Windows 8 thing? Grateful for someone else / Steinberg to test on a W7 64 bit machine.

I haven’t noticed any changes with the functionality of Artist Mix or Control and both seem to be working perfectly well in C8 / Win 8.1. I had to reprogram my soft keys as it seems Eucontrol views C8 as a completely separate application from C7. See the thread mentioned above… looks like it’s possible to copy your old soft key settings by location the .xml file.

Still having W7 problems. V frustrating as I see W8 is fine and mac seems fine (with the preferences hack). Can’t really think of what else to try to kick autobanking into life. It’s such an essential part of my workflow, it’s stopping me jumping into C8 fully.

No! … Follow the procedure outlined on this page for initializing your preferences HERE!

This has cleared many unexplained gremlins for me in the past!


Thank you - got it! (well, the Windows equivalent here - ) . Shift / cntrl / alt is supposed to do exactly the same thing on a one-time basis, interesting that it doesn’t!

So I played around a bit to see what breaks C8. I’ve been able to load back Default Project Workspace, Key Commands, Plugin Manager and Plugin xml files fine. The problem one was UserPreferences.xml - that seems to be the corrupt file which won’t autobank EuCon.

Thanks again Al, back up and running with C8! :slight_smile:

Autobanking restored - preferences needed trashing completely ( ). The corrupt file was UserPreferences.xml - was able to put other preferences back once C8 had been remade from scratch. Thanks to Al for his help on the Issues thread.

Oop, no, broken again. Something breaks autobanking. Still investigating.

DOH! Found it. And it happened to me 2 years ago, and I forgot. Not broken at all - of course EuCon doesn’t autobank if project and mix windows aren’t synced.

Phew, drama over.

Ha ha ha ha…

Found it. Wasn’t the preferences, it was me being an idiot. It happened to me 2 years ago, and I forgot. Not broken at all - of course EuCon doesn’t autobank from the project space if project and mix windows aren’t synced.


Nothing to see here… moving on…