Cubase 8 Crash with plugin MPC.vst

when I start Cubase when plugins are charging, to get to the MPC software (MPC.vst) plugin closes unexpectedly forcing me to restart the cubase, but has restarted again I feel the same. what can I do?
Thank you.

Macbook Pro Retina 15: OSX Version 10.11.3
Cubase Pro 8: Version 8.0.35
MPC Software: Version


I have the same problem : I bought an Akai MPC Studio yesterday, I installed all the files (cd version and downloaded on Akai’s website).

The MPC software works fine with the MPC and the expansions (the 809 and the Bank).

But I can’t launch Cubase pro 8.5.0, it crash during the initialisation of the VST 2x. plugins MPC

I sent a message to Akai and Sternberg … waiting for a solution…

If I delete the Vst MPC files of my library, Cubase can start again… But I can’t use the MPC as a plugins of course.

Did you find a solution ? Did you contact Akai and Sternberg ?

same problem here.
Cubase Elements 8 and MPC Studio Software :frowning:

Have you received an answer from Akai or Steinberg?

I have the same problem, and got a reply from support saying to un-install the MPC completely(delete and the mpc.vst from the Library->Audio->Plugins->VST folder and empty trash), download and install the newest version, and make sure to run and authenticate the MPC in stand-alone mode before opening Cubase.

I did this, and it still doesn’t work. Help!!

Im having this problem too…

I would really like to use MPC within cubase

Same issue here. Not sure if this is an MPC bug or Cubase.

Found a solution:

Hello everybody.

This worked out well with Cubase 8.5
does anyone has a clue how to do it with Cubase 9 ?

Thx everyone !

// UPDATE //
→ This works the exact same way with Cubase 9

i have still a problem with this… the mpc plugin is working, but when i close a cubaseproject that used the mpc plugin… Cubase is crashing and i have to restart… any solutions for this?

The method provided on the Akai community was figured out by me yes it will work on Cubase v 9 here the post under the name Kerh Seker Shemsi form the Aksi community.

Kerh Seker Shemsi 1 year ago
I had the same problem. For All cubase version Cubase 8.5 Artist/Pro and Elements
I do not Know what OS your using but I resolved it on El Capitan OS X >

You do this By removing the MPC VST Plugin from library/Audio/Plug-ins/VST and remove MPC.vst. it will end up in trash do not empty.

Start or Restart Cubase 8.5 go to device/plugin manager. go to trash right click on MPC.vst and select put back. Go back to Device /plugin manager and select the rescan once it find the MPC.vst Cubase will crash restart Cubase 8.5 and it might fully load it works for me. Once in awhile you may have to repeat this until either Akai or Sternberg figure out the Issue.

I just had to do a clean install on My iMac pro 27" retina late 2015 because prior it did not work after the clean install this method is now working. I also contacted Steinberg and Akai. Steinberg stated that Akai need to contact them for a working solution it appears Akai as not done so as of yet.

I am having this problem currently, and i have tried the work around listed in here and the Akai website. Nothing working. Haven’t been able to use Cubase in months. Thank god i have another Daw. Really frustrated!

Hi Guys,

MPC also recently launched a final version of MPC.2.0 ( so this is not the BETA version any more). LINK >>

Try to reinstall it … The software is available in your AKAIPRO ACCOUNT… it helped my problem !

This has come up a few times here, and I’ve passed it along to our team. It seems to only affect later versions of MPC and later versions of Cubase/Nuendo.

I’m still not sure which software is causing the problem, but there’s a simple workaround:

  1. Move MPC.vst away from Library/Audio/Plug-Ins/VST.
  2. Launch Cubase and click Create Empty.
  3. Move MPC.vst back to Library/Audio/Plug-Ins/VST.
  4. In Cubase, go to Devices->Plug-in Manager.
  5. Access the Plug-in Manager Settings (gearwheel in the bottom).
  6. Click Rescan (top-right corner of the Plug-in Manager Settings).
  7. Cubase may or may not crash - launch Cubase again if it does.
  8. MPC may now be loaded as an Instrument in Cubase.



sorry for not getting too in depth with my last post, this is an edit.
i had this issue again installing mpc studio black on a windows 10 pc with cubase.
the solution was similarwith windows, see below the differences :


  1. Move MPC.dll away from C:\Program Files (x86)\Steinberg\vstplugins ( i put on desktop)
  2. Launch Cubase and click Create Empty.
  3. Move MPC.dll back to C:\Program Files (x86)\Steinberg\vstplugin
  4. In Cubase, go to Devices->Plug-in Information
  5. Click 'Update Plug-in Information" button. This will rescan for plug-ins
  6. Cubase may or may not crash - launch Cubase again if it does.
  7. MPC may now be loaded as an Instrument in Cubase.
    (launch mpc by going to devices - vst instruments and select mpc, then a select yes when it asks to create new track)

so i can help you guys if you have this issue with mac or windows, let me know :slight_smile: