cubase 8 does not 'hear' piano via Alesis io2

Hello,

I have downloaded the Cubase le 8 software and updated it, on to my Macbook.
I have Alesis io2 installed, and usb to my macbook.
I have a Yamaha p-115 digital piano cabled into the Alesis (line input).
I can hear both the mic and the piano over the headset (headset is plugged in to Alesis midi).
I can record the vocals through the mic, so the mic sound is passing through Alesis io2 perfectly to Cubase.

Problem: the piano (yamaha p-115) signal is not picked up by Cubase. I created a ‘piano’ in Cubase, input is io2, but the default is Halion Sonic SE, and I can’t find or see or connect the yamaha piano in cubase. I tried the same with creating an ‘instrument’ and a ‘midi’: same problem.
In Device, MIDI device manager, i can’t see Yamaha p-115 (should this be any part of the solution).

How do I make Cubase hear and record my yamaha p-115?

Hi,

Add a Stereo Audio track. Set Alesis IO2 as an Input.

I don’t understand your headset connection. I guess it’s not connected to MIDI.

Thanks for your reply, but I dont understand. I have added (successfully I hope), 3 images/screenshots to this message.
-I cannot choose a bus, stereo nor mono, in the piano track
Schermafbeelding 2016-04-23 om 11.17.49.png
-I cannot add a stereo bus (will not connect to io2)

How do I make cubase hear the piano? Should I not make a ‘piano’ audio track, but a ‘midi’ track or other?

I ve tried adding the piano in Device Manager, (is that necessary at all??), but cant find yamaha p-115 nor similar.

Hope to hear from you!
Schermafbeelding 2016-04-23 om 11.17.20.png
Schermafbeelding 2016-04-23 om 11.17.31.png

Hi,

To make Cubase to hear the piano, you have to add a stereo bus. You already have one Stereo Input Bus in your VST Connections > Inputs. Change its Device port from Not Connected to Front Left and Front Right. If you have another device connected to these inputs (like microphones), you have to unplug them, and plug jacks 6,3 (out from your piano to In of the Audio Device).

Remove the Instrument track, and add a MIDI track. Set Input to All MIDI Inputs, and Output to iO|2.

Add a Stereo Audio track, and set it’s input to Stereo In. Enable Monitor on both MIDI and Audio tracks.

Hi Martin,

Thanks, it works! I can record both voice and piano now.

This must be a silly question, but i can’t replay both piano and voice at the same time, to hear me sing and play at the same time. I can put the cursor on either piano or voice and hear it replay, but not both at the same time.
How do i replay both voice and piano and hear them simultaneously?
Thanks so much. Elroy

Hi,

Make sure, the track you want to hear (is already recorded, and you want to playback it while recording the 2nd track), has Monitor switched Off, please.

Hi, Martin,

I dont want to record one track while I hear the second track.

I just sing and play the piano at the same time, and record them at the same time. Now I have two tracks recorded. I want to hear what I have just recorded, and replay both tracks at the same time.

However, I can’t seem to be able to replay/hear both tracks at the same time. I can only move my cursos over one and hear recorded tracks separately.

How do I replay both tracks simultaneously, and hear my recorded voice and piano at the same time?

Hi,

Could you send a screenshot of your project, while playback, please?