Cubase 8 error win7x64 "opening error" "aero theme" etc.

Hi :slight_smile:

Just installed c8 …

When i want to open it for the first time, i get this error message:

Error
DWM composition is not running. Please switch to an Aero theme.


I like my “windows classic” theme…

Do i need to use Aero theme now (more resources used for aero than basic) for cubase?

Greets:)

Hey,

You can use the Window 7 basic theme, which I think look like you classic theme, but uses AERO.

SLL

Hey ssl

Thx for the help, but,

I use the “windows classic” theme.

All the text and boxes and everything looks good that way for me. Even if i compare fonts and colors of the two themes and adjust the aero theme accordingly , it does not look the same. (Text in cubase is weird too if its not classic)

Also the windows 7 basic theme looks weird compared to the classic. - also, i get the same error message when i use this theme…

Also, when using an Aero theme as suggested by annoying error message, when i click through the cubase menus up top, it creates a sort of overlay … (Menu name superimposed over same menu name) -

Pwease steinberg, deactivate that silly DWM thing… Thxxx:)!!

-> also, switching between mixer and arranger fullscreens leaves funny screen residue on the next screen view…
-> also switching between mixer and arranger causes cpu spikes at times.

->Also, why on the top menu bar , in the empty space between the steinberg hub menu on the left and minimize etc buttons on right, does it say cubase pro etc… -> Edit->guess not a bug…

same problem here, can’t open cubase without aero theme. This sucks.

Hello,

Yes, Cubase 8 needs the Aero mode to run in Windows 7. The technology in the new improved window handling introduced with Cubase 8 requires this setting to be turned on.

Hey crohde
Thx for the info.

Thats erm… A let down… >rant>pout>sniff>sob>?

Also, the improved main cubase window cannot be minimized… (Cubase missing minimize etc)

Also, changing screens (from arr to mix) as stated above-> 80%cpu average load goes to +100% into the red when toggling F3…

Also, something weird is going on with my remoteSL (not mkII) gotto troubleshoot…

Pls crohde, help us! Too much is falling apart (for me) upon first minutes…

:cry: Same here…

I switched on Aero but that didn’t solve it. Still get the same message:

Error - DWM composition is not running. Please switch to an Aero theme.

Same here. Got it sorted out by restarting computer and selecting the aero theme again in Windows. Now cubase 8 launches. :slight_smile:

Unfortunately that doesn’t work for me. I stille get this message:
“Error - DWM composition is not running. Please switch to an Aero theme.”

Cubase 8 doesn’t work. Damn! I foolishly bought it without trying. This sucks.

Win 7 64 bit. After install of Cubase I clicked the shortcut (opened as administrator just to be sure) got an error message. I should repeat it all here but I can’t remember it all (sorry) :slight_smile: .

Anyway solution is …go into windows performance options and tick ‘enable desktop composition’

This enables Aero

Now the icon works here, Cubase is installed and running… have not yet looked to deep.


Now… how to get rid of Aero???

Anyone…

http://www.ghacks.net/2010/12/20/how-to-disable-windows-aero-transparency-in-windows-7/

Like a lot of us I suspect, I had Aero off on my DAW. I had to turn it on to get the C8 shortcut to behave.

This left me reading file menu items through a haze - uggh!

the above link show you how to get rid of this.

Z

Edit: this might be a graphical card issue. I have a HP Z400 Workstation and I found a pdf with a notification that the graphic card, in despite of all specs and local settings in Windows, does not support Aero.

In other words: I can switch on Aero but it simply doesn’t work… I’ll keep the forum posted.

Tnx, but,

i can do what i want with the settings of an aero theme, it never looks as clean, sharp and homely as the windows classic theme…

Still hope that steiny can find a workaround for this mandatory Aero theme thingy… The GUI is kinda corky for me atm…

co sign, not a huge deal but if its possible please get rid of the dependency on Aero

thanks for the link

thanks, got rid of this useless transparency thing thanks to your link.

i found out this version won’t let me run unless i have aero on, which i normally avoid.

is there a way for windows to technically have aero on, but force windows to have the somber xp/nt look?

I saw a mod say no, in another thread. There is a way to fix Aero to look more standard get rid of the transparency, its a bit of a cpu hog on older systems, but it should not bother a decent system. Its needed for the new gui

Z

I wonder if the WHOLE aero theme is really needed or if cubase just has a specific dependency for a feature of it (only dwm.exe and its dependencies)??

Really do hope that something can be done… Seems like an easy way out of the cubase windows management issues strange how other daws dont have these issues and aren’t in need of an aero theme… Definately not an elegant fix… In my eyes this is more of a painful workaround.
The menus bar on top is also weird. When i close cubase, im left with a small permanent blank cubase bar on top. This i have to close again for cubase to close the way it should have the first time.
But whats this? What is thhere hidden under the blank top menu bar? Another menubar- with options…

“Imagine fitting meme”

I would prefer them to take advantage of Aero rather than have an old system for the few people who do not have it enabled