Cubase 8 MIDI record seems impossible!?

I’m embarrassed to ask this…
I have a Korg PA, with it’s MIDI channels on playback I am trying to record onto the PC (Win 7 64-bit)
Works fine to an iPad and Cubasis
Works a treat with Sonar LE but when trying Cubase LE Elements 8 I get zilch!!

  • exactly the same MIDI set ups
  • each track armed for record

It must be something I’ve overlooked in Cubase but have spent days reading the manual and trying various things
30 day trial expires tomorrow :frowning:

Help me get digital please!

A screenshot of the inspector for that track would help but, for starters, are you seeing “MIDI Activity” in Cubase when you press the keys?

Hi Jaslan, Hope I have attached screen shots OK.
Yes the transport bar is showing MIDI activity window moving up/down

I see you have MIDI channels 9-16 selected on those tracks. What channel is the keyboard transmitting on?
Perhaps try changing one of the channels to any, all, or omni (something like that).
Also, click the number pad just left of the MiDI channel (9 in your picture) and have a look at the settings. You might be filtering the channel your controller is sending on. That would explain that Cubase sees midi activity but none is making it to the track.
I honestly can’t remember where the track midi filter settings are but search for that and check it out.

Tried your suggestions…no joy.
I will try a new install on my laptop and see if that is different, plus I get another 30 days hopefully :smiley:
Probably next week now…

OK new trial running on a laptop… it seems to be a filter issue before, but now I can’t open that version on the desktop PC. Filtering is via the preferences menu in the file tab.

I now can track record into Cubase, however the BIG problem is that each track on Cubase records all MIDI activity rather than the tracks specified. I have switched off the All MIDI tick in the MIDI Device Setup, as recommended by the manual but stubbornly all I can do is select Pa3x Keyboard as the input, no possibility to select the individual channel. It doesn’t seem to reflect the Pa3x Sound output channel set in the Inspector bar.
My Cakewalk Sonar LE does not require any special input MIDI channel selection, and happily records 16 separate tracks using the same Korg USB MIDI driver. I’ve tried a different MIDI driver via cable - same result - Cubase 8 LE does not want to separate the input channels

  • is this a known limitation I wonder?
    Grateful for any further suggestion, as always :slight_smile:

The “All MIDI Inputs” only allows you to discriminate between different MIDI devices as the input. The discrimination of MIDI channels can be done by using the MIDI “Context Gate”. Load it into a MIDI Insert slot, put it into MONO mode, turn on Channel and select the appropriate channel. Also, turn off the other context mode, I think it was key range or velocity, something like that. A very powerful “filtering” MIDI tool…


HTH
J.L.

Hi Jas,

using the MIDI "> Context Gate> ". Load it into a MIDI Insert slot, put it into > MONO > mode, turn on Channel and select the appropriate channel. Also, turn off the other context mode,

I’m using Cubase 8 Elements LE, I can’t find these topics anywhere in the programme or in the manual

  • do you mean loading a track preset? The closest description TrackPreset Midi is ‘monophone arpeggiator’
  • MIDI insert slot -> you mean the Insert/Sends pop-up when clicking on e in the track inspector?

The user manual (page 222) refers to the routing on the MixConsole screen but this only reflects the same settings as the Inspector tab whereas the manual implies “For MIDI channels it allows you to open the Input Transformer”

Sorry but I am still mystified :cry:

Must be a limitation of Elements. Some of the MIDI inserts are not included.

Hi Jas, I contacted Steinberg and they confirmed Elements has this limitation, the Input Transformer is only in Pro or Artist… So I have ordered Artist! I hope I will have no regrets :smiley:
Once again thanks for the help

OK Jas, I’m up and rocking now… with the Artist version.
Just one extra step on the above advice you gave was to hit the little “Record to Track” button in the Inspector/MIDI Insert window
Why it is so complicated compared to other stuff like Sonar only, only the creator of the software knows.
Many thanks
Tim