Cubase 8 not starting after upgrade from 7.5


I bought the upgrade of Cubase Pro 8 from 7.5 today and received the conformation from Steinberg with my license key.

I installed it and activated through eLicenser with the new code and the Cubase Pro 8 license is shown and it also shows it was activated on Steinberg’s website when I go into my account.

However, when I click to open Cubase 8 it doesn’t do anything. Nothing comes up at all.

Cubase 7.5 still opens so the dongle,is working fine.

I’ve restarted several times and still no luck.

Any help would be appreciated.

Assuming you’re on Windows (please add your spec to your signature) if you open task manager do you see Cubase appear in the applications list?

Have you tried browsing to the install folder and starting it directly from the exe rather than the start menu.

And to be clear when you say nothing happens, you mean nothing at all, no window appears at all??

Hi Grim, thank you for your message.

Sorry I should have given more information regarding my operating system. I’ve added my specs now.

My problem has now been sorted, but for the sake of reference I’ll post everything below:

when I clicked on the Cubase icon (from desktop, start menu and installation folder), nothing happened at all. Literally, nothing. I checked in task manager and Cubase wasn’t listed in the Applications or Processes list.

I then installed it on my older PC which also has Windows 74-bit on and it worked fine. So I bit the bullet and did a format on my system and re-installed Windows. This time after I installed Cubase and tried to open it I got an error saying Cubase 8 stopped working…no additional information.

But after I’ve installed Service Pack 1 and all the updates it’s working fine now.

Same problem here, after updating from Cubase 7.5 to Cubase Pro 8…both versions caput :\

After uninstalling Cubase Pro 8…Cubase 7.5 works fine.

Any help?

When Cubase 8 scans the plugins at startup, if any plug in throws a dialog or error box, Cubase 8 will hang.

I had that problem, and had to move a bunch of older plugins out of the scanned directory.