Cubase 8 Pro download where has it gone ?

Hi There,

I have just bought and upgraded to 8.5 and then ended up having to reinstall my whole computer as 64bit crashed my system and left me stranded. 32bit worked fine. Problem i have now after too many hours of major reinstalls of not so small plugins ect , standard cubase 8 pro is gone from my steinberg account and only gives me the new download which for me atleast didnt work. the last version for me worked pretty damn good. Please can somebody point me to where it has gone too, or has it been taken down permantly. Version 8 pro is what i need, only the update to 8.0.30 is still availabe. normally i keep the downloaded install but thought i was being cute getting rid of unecessary large files. Any help will be greatly appreciated. Somehow I dont think i will be alone in this request.


8.0 should still be on your computer unless you uninstalled it after installing 8.5.
I have Cubase 7 and 7.5 and 8 and 8.5 installed without any issues.

I just checked the my steinberg/my products page too. It’s only got 8.5 available for download even though I’ve been using Cubase for ages. Possibly email support and ask them for a full version 8 download link?

Hi there,
thanks for all your input. Yes peakae I still had 8.0 installed but unfortunately I had to reinstall completely after the crash. Hence I havnt got it now. I just couldn’t get the system up and running again no matter what tricks I tried. I will drop support an email and see how I get on . thanks lads

While the 8pro download will disappear from your ‘My Steinberg’ downloads section and you will only now see 8.5 you can still download any full version all the way back to Cubase 6 in the Steinberg downloads page . Main web site, downloads, select drop down menu for software and select what you want. :wink:

EDIT- I just checked the download page and it has been removed from there as well now. :imp:

yep that’s why I ended up posting this here. I still have a non functioning Cubase 8.5 pro so I am waiting on word back from my support. I asked if I could be given access to version 8 again. I wiil let you know what I find out when they get intouch.

Aren’t legacy files still available from the ftp site? always used to be…

Looks like it hasn’t been updated in quite a while.