cubase 8 pro : gm map setting mutes halion vsti


I use some of the drum kits in Halion sonic se. And previously worked in cubase 5 and the older version of Halion.
Now when I use the same midi input and use the GM map setting for that track sound get muted. Switching back to “no drum map” returns the sound. It may seem as a small issue but editing drum midi with the keyboard layout is not preferrable some times. Using the groove agent sound works with both settings for the same track.

anyone else encountered this issue? And more important did you find any cure?

thanks in advance


Check your midi channel.

GM drum map defaults to midi channel 10.
You drum kit in HSSe is probably set to channel 1. That’s why you get no sound when using drum map.
To fix this open drum map setup and change the midi channel to 1 or to Any.
If you hold Ctrl while selecting midi channel, it will change it for all the notes so you don’t have to do it one by one.
I think you can also do it from within Drum editor.

Great. I will check it out.

Thanks :slight_smile: