Cubase 8 Pro License Gone!

I have a problem. Out of nowhere my Cubase 8 Pro will not start claiming that I have no valid license. I purchased CUbase 8 Retail version via Amazon and then Upgraded to Pro version. My eLicenser does not show my license for Cubase 8 and when I try to upgrade it just says something like “there is no license to upgrade”. I erased registration on My Steinberg in order to re do it but I can’t for some reason.

Please help me, I need to get work done as soon as possible.



You need to supply a little more info for clarity.

So you have an elicenser dongle…you activated your C8 pro to this dongle a while ago (how long roughly?) and now the license is missing?

What do you mean by you’re trying to upgrade it? You presumably did this before so this isn’t what you need to do.

  1. When you open elicenser manager is the dongle recognised?
  2. Are any licenses at all showing on the dongle? What are they?

I had a similar Problem and it turned out that the dongle had to be changed.
Sometimes cold restart of the Computer helped.

It is probably a Problem with the dongle and its usb-connection.

Cheers, Ernst

PS.: I was lucky in that sense, that sometimes the dongle worked which allowed me to Transfer the licens(es) to a new dongle. From that Point on it worked reliably again and i could dispose the old dongle

Downgrade of the eLicenser software can also the source of loosing licenses. You do not really loose the license but the database with the software doesn’t recognize the entry on the dongle, running maintenance tasks is a good option also.

Thank you everyone for your input. It turns out that my dongle was broken and got it replaced.