cubase 8 punch in macro does not work in 8.5

Basically the "activate punch in " command does not toggle off when transport is stopped - so the next time i run macro it effectively toggles it "OFF " and no punch in is recorded - i have to manually disarm punch in to put it in off position -then run macro

In 8.0
" go to left indicator "
"auto punch in "
"start "
When transport is stopped the "auto punch in reverted to off state…rinse and repeat :slight_smile:

IN 8.5
go to left "
“activate punch in” - there is no “auto punch in” anymore
When transport is stopped “punch in” remaines activated - forcing a manual reset or else next macro run toggles it to "off state. :open_mouth:

I know this must have something to do with new punch in locators feature? Any ideas of how to achieve this macro with other commands? -thanks


What is the use case behind, please? What do you want to achieve by the Macro? Do you know, you can enable or disable Deactivate Punch In on Stop in the Preferences > Record?

Ha - Well there you go! that must be the difference! - :blush: I really wish Cubase would not trash your preferences every time you upgrade, i had forgotten about re- ticking that one. Thanks!

btw - reason is i just like to record ,then immediately listen back to take, WITHOUT still being in punch in record mode.

thanks again

The preferences should be overtaken from the previous Cubase version.

if by overtaken you mean previous preference settings transferred automatically to your newer version, they are not in my experience. I always have to re click “treat muted events as deleted” tapedeck recording style" and others - i did try to backup from old and and import preferences settings - but was unsuccessful. thanks again.

It can be a little hit and miss, with the transfer of setting. Thankfully we can now in 8.5 export the settings, I hope that will remedy such issues in the future.