Cubase 9.5.3 - Key Editor automatic zoom

Hello All,

In Cubase 9.5.3, when I double-click on a container, then I go to the step editor. OK
I know that it is possible to zoom to see all the data of the container with shift + E. OK

But, how is it possible to see automotically all the data when I go in the step editor ? (without make shift + E)…
I use step editor 100 times by day, I hate to have shift+E each time…

Thank you !

Hi and welcome,

What do you mean by “Step Editor”? Do you mean Key Editor?

I would recommend to make a macro:

  • Open Key Editor
  • Zoom to Event (Shift + E)

Yes, key editor (sorry !)
Never used Macro but I will try. Should not be too complex if only 2 lines !

Thank you :wink:

Well, tried thir morning.

Macro is ok but, for it to work, I have to call it in the macro menu (or to create a shortcut)

I would like that the macro works automatically when I double-click on a container and go to the key editor.

I googled it during few hours about it and no solution.
The only way is shift+E or call a macro…but when you open 100 times by day the key editor, this is a pitty process…

Hope Steinberg will fix it.

Hi,

There for there are Macros in Cubase. When you do it 100 times per day, make a Macro.

Yes, but the macro is not applied directly after double-click on the container I need to edit.

Option are :

  • double click on the container (open the key editor), then SHIFT+E
  • or select the container, call the macro with a shortcut

I think it’s not user friendly and that you lost time if you have to do it 50 or 100 times.

Probably Steinberg shoud consider to add a Preference option -> open key editor / full zoom

Other DAW can do it perfectly…

Anyway, thanks for your help and time :wink:

In my experience, it seems global. If I double click on a part and zoom in, all the other parts are zoomed in when I click on them. If I zoom out in any part, they all are zoomed out.

Not on my side but thanks for the idea (and I will check again if there is something in the global preference about it)

I’ll check next time I’m on too.

Hi,

Zoom level is a global settings in general (no preferences about this in Cubase), but Zoom to Event is not a Zoom Level. So if the MIDI Parts have different length (the probability of quite high, I would say) then it doesn’t work.

Btw, my wish how should the editor open is exactly opposite. I would like to keep the Zoom Level and set the center of the Key Editor view to the exact place, where did I click to the MIDI Part in the Arranger/Project Window. So I would keep my focus view, but I could code the area of the focus just by double click to the MIDI Part.

Checked this morning, you’re right.

It makes also sense. Workflow is different for each user.
I think I will have to accomodate with Shift E !

Thanks for your time guys :wink: