Cubase 9.5.30 maintenance update available

We have just released the Cubase 9.5.30 maintenance update for the Pro, Artist, Elements, AI, and LE editions. It’s a maintenance update so one can obviously expect issues to have been resolved; then again, there weren’t many so you probably won’t even have noticed them in the first place. Alongside the fixes, this update also includes enhancements to Direct Offline Processing and other features. For detailed information, please refer to the corresponding version history on the download page.

Download Cubase Pro 9.5.30 Update

Download Cubase Artist 9.5.30 Update

Download Cubase Elements 9.5.30 Update

Download Cubase AI 9.5.30 Update

Download Cubase LE 9.5.30 Update

I’m first off the rank.

Great work.

@ Matthias,

Could you also omit the words "An issue has been resolved where…

very tiresome to read over many and varied bug reports.

One other thing, is there any reason why an update can’t run simply because another application is using the eLicenser?

In addition, why not have eLc downloadable from the Steinberg Download manager.


Error: An installation package for the product cannot be found, error code 1603.

I managed to unpack the .exe using 7zip but I am getting network resource errors, which were only remedied by unpacking the original Cubase 9.5 installer and navigating to that via the MSI installation program.

The issue of dragging the project view while autoscroll is enabled is still there but is now only occurring once, i.e. you cannot continually drag so I’m supposing this will be fixed in a future update. It is still not possible however, to click once in empty space of the project page or key editor in order to turn it (autoscroll) off, which previously was allowed, nor is it possible now to hold a note or tempo event and have autoscroll switch off automatically after the project cursor has passed the viewable area of the page.

Tempo editing in general is more solid, which is always the case with updates and I am getting less overplay via the network, e.g. with Vienna Ensemble while editing tempo events live.

Many thanks for looking at these problems so quickly.

I think we got an issue here…I will have a look at it.

Well, it’s a technical reason due to the implementation of the copy protection in the application.

Would it be more convenient if you would have to download the eLicenser and install it rather then just open it and start the maintenance? But yes, it sounds reasonable to have the eLic Control Center also available for download in the SDA.

I will pass your feedback to the team. Thanks!

The track selection issue I reported here
is fixed :smiley:
'cmon here, LET ME KISS YOU GUYS!!!

Before I update komplete kontrol 2.2 has this fixed the instant crash on boot (Mac 10.12.6)

maximizer broken after track freeze issue not fixed. it was reported and logged as bug two updates before, it makes me very sad :blush:

Installed update on mac os 10.12.6. Installation went well but Cubase won’t start anymore. Tried re-installing. It crashes when the splash screen shows:

“Initializing: VST Control Room”

dling now, ty

where i can found old 9.5.21 new update crash !!!

me too crash on “Initializing: VST Control Room” OS X 10.12.6

For new projects yes, but the "bug "has been saved in all the project files that are saved in pre 9.5.30 (started with 9.5)
How is that for you? (or anybody)
Well thats what im facing.

backup project thit not work…

open in 9… saved again and open in 9.5… thit also not work

Direct Offline Processing

The update covers the most of the bugs and the new DOP now make sense :slight_smile:

except for one bug that still exists. (appears when you are trying to process many excerpts)

For example:
When you are trying to process 1, 2, 3 to 49 excerpts (maximum) (all together selected),
with a pitch shift command (without time correction),
all excerpts changing their length like should be.

From more than 49 excerpts the function is not working correctly anymore, the length size stays the same to the most of the excerpts!

The update works and installs. I had on the project currently working on no probs.
It seems the Elicense is not the lastest version but runs. I downloaded the latest EL and works ok.
So no probs here.

Now it instantly crashes when trying to load up the project I was working on only 30 mins ago… I have like 100 different saves of that project at various different stages in it’s creation and I can’t find a single one that will even try to load.
Mac OS 10.12.6

My patience is SERIOUSLY being tested right now.

Can you zip and upload the crash report?

upload to the forum?

Edit: This forum is like something from 2003 and doesn’t have a file upload?
So where do I upload it.
I’m about to go for a walk to calm down because i’m getting very frustrated.
I guess i’ll be reinstalling Cubase later

I confirm. So it’s half fixed. Sorry Stainy, have to withdraw half of my kiss.
Project templates are screwed as well, not only projects. Many of those templates were saved long time ago, under ver 8 probably

A walk is always a good idea! Thanks for that.

This forum is the 2.0 update to the 15th century Gutenberg press, so yes is dated. :wink: But you will have no problem uploading the zipped crash file via the “Attachments” tab. :smiley:

crash log.
Repeatable. By that I mean it happens EVERY SINGLE TIME.
It’ll no doubt show you absolutely nothing useful… (25.7 KB)