Cubase 9.5.30 update issue

Hi there!

I’ve updated my SX2 to 9.5 thanks to the recent offer that Steinberg has launched.

I have installed and opened 9.5 without problems. My audio card is perfectly recognized (Focusrite Scarlett 2i2), and all seems to be ok. But when I have installed the 9.5.30 update all of a sudden my card isn’t recognized anymore, and at Cubase start staging I receive an alert that “Media Service component is missing”. If I uninstall Cubase and then reinstalled again, it works ok untill I update to the 9.5.30 version. Each time that I install this patch, I’ve got a fail start, and the card dissapears from my VST audio system again (please, see attachments).

I have trashed preferences too (USER/AppData/Roaming/Steinberg/Cubase 9.5_64), but this doesn’t solved the problem neither.

What can I do to install 9.5.30 version successfully?

KInd regards.

Issue (1).jpg

Latest driver/firmware on the 2i2?

Hi raino, thanks for your reply. Yes, the driver is updated, but I think it’s not related to the 2i2. I’ve uninstalled all Steinberg’s software (Cubase 9.5 and SX2), and also the Focusrite driver. I’ve use CCleaner to cleanup the Windows registry, then I’ve reinstalled Cubase 9.5 only, and Iv’e used the MOBO’s card to test, not the 2i2. Same results. All right with 9.5 if I don’t update to 9.5.30 version. Once updated, same problems: No “Media Service component”, and the soundcard is not recognized (MOBO’s soundcard this time). It’s very frustrating.

Kind regards.

When you have 9.5.30 installed and Cubase can’t see the interface can Windows access it?

FYI we encourage folks on the forum to put their system specs in their signature because it helps when trying to understand some problems. Guess what, you’ve got one of those problems. :wink:

Another thought. When you have only 9.5 installed make a copy of its .exe with a slightly different name and in the same folder, for example Cubase95-test.exe. Now when you upgrade to 9.5.30 you can run both 9.5 & 9.5.30 side by side. Does 9.5 still run OK, or is it broke now too?


I have a similar issue and would like to know if there is anything new on this topic? I had a Cubase LE AI Elements 9.5.10 perfectly running on my Win7 (i7). An update to 9.5.30 came up with the following issues:

  1. “Media Service component is missing” on application launch.
    On opening a project:
  2. Several warnings: “The plug-in xxxx could not be found for xxxx Channel xxxx”
  3. Missing Ports Window showing that my Tascam US-200 audio interface is not mapped.
  4. Missing VST-Plugins in “VST Plugin Manager”.

I copied the “mediaservice.dll” from a backup of 9.5.10 to 9.5.30 and that solved only point 1).

Next I tried what you suggested: uninstalled everything and made a new install of 9.5. This version run without a problem. I renamed the exe file and upgraded to 9.5.30. Running the renamed 9.5 exe file just gave the same errors and warnings as did (and does) the 9.5.30 version.

I have to mention that there is something “special” in my Win7 setup. I have installed the 9.5.10 on drive “E”, not on “C” as is the default. I did this because I had some Win7 profile issues a few month ago and had to delete and recreate my user profile several times. Therefore I put all my data and also Cubase on drive “E” in order not to loose data in case of a Win7 re-install. When launching the upgrade from 9.5.10 to 9.5.30, the upgrade program did not detect my Cubase installed on drive “E” and hence did not allow to upgrade it. Therefore I made a new install of 9.5 on drive “C” and next I upgraded it to 9.5.30. My 9.5.10 on drive “E” still runs without issues, but I fear that there might be something messed up because of drive “E”.



My friend had this exact issue.
Doesn’t connect his PC to the net and is anti-updates of software.
Convinced him to upgrade to v9.5 which works fine, but once we installed 9.5.30 we got the media services error.
Spent all night reinstalling and needless to say he now won’t touch 9.5.30 lol.

(It’s bad enough losing the Steinberg legacy plugins cos 32 bit, so installed 8.5 too which also works without error)

I concluded it could be a mixture of his sound card (edirol ua25) which isn’t officially supported on Windows 10, though it does work on 9.5 and 8.5, or maybe an issue with the installer from full 9.5 to 9.5.30.

Other thing to note about the Media Services error means it still runs but the Hub left panel is missing.

My friend was happy about that as principally saw it as a page of Steinberg adverts which he doesn’t want cold selling when trying to make music lol.

The other impact will be the PDF guides have been removed for some silly reason, instead Help directing you to the Steinberg site. Which for users that don’t want their rig connected to the net is useless.
Surely a few Mb in the installlers can be used for PDF manuals?