Cubase 9.5.40 update available

I just try it….and is working….
I tried to record from 4 different inputs - simultaneously (mono and stereo channels)
I try to record from channels inside the project that goes into a group channel
seems that is working …

did you try it in a different computer? (just in case)
and I hope you have a backup of the previous version that was working…
(best thing is to copy your steinberg folder always before any update)

I don’t mean that because is working here should also work to you…

That’s why I believe that there is something that Steinberg miss here ….
And for sure I respect and understand your point of view, but you are not alone here,
the most of the people here are professionals and everyone here want this daw to work finally as it should …
And for sure this is not your problem like a client, or my problem, you pay for something you are expecting to work because you have your own clients that they cannot wait …Steinberg or the weather to be sunny…

If you follow the last years of Steinberg updates, you will notice that
this is happening in every release ….
and Steinberg never takes an official responsibility ….

And from the moment that is not doing it,
or you switch in a different daw or you trying to give ideas…
so mayyybeeeee FINALLY someone takes seriously the situation ….

The Idea of beta testing is not new, the most of other daw’s working like that,
because they had the experience that not all users using the software in the same way and is better a group of people to do that, and not the programmers.
Programmers thinking with the programmer mind, they have the list of bugs every time and focus on those ones, without checking the rest of the functions if they are really working. (because in most of the cases they don’t have time, and maybe now they are working in the new release and already 9.5 is a finished story for them…)
And that is the problem of Steinberg Policy, that they don’t force their own beta test team to work as it should …
Users are not like that…
This is the most basic lag of all software companies around the globe….

Is there a way to get the 9.5.3 update? My Notebook has a fresh Windows and I have a recording session tomorrow…

I tested recording on my system. With the console fully loaded all 32 channels armed and loaded. I had no issues tracking 26 mono channels and 3 stereo channels. Was no way for me to reproduce your issue.

I track to a ssd with 512mb buffer and I use the 32 bit sound engine. Looking at your video, it dosent seam that cubase and your OS bother to “spinn” up your disk at all.



'On Windows you can roll back without uninstalling/installing anything: Control Panel -> Programs and Features -> View Installed Updates -> Click the Cubase 9.5.30 entry and click uninstall.

If needed 9.5.20 can be found here:
download.steinberg.net/downloads_software/Cubase_Pro_9.5_and_Cubase_Artist_9.5/9.5.20/Cubase_9.5.20_Update_win.exe
download.steinberg.net/downloads_software/Cubase_Pro_9.5_and_Cubase_Artist_9.5/9.5.20/Cubase_9.5.20_Update_mac.dmg

Hello,
Thanks for this update. But what about the update to turn Cubase (like Nuendo) in ‘a full blown VR production platform’ as you stated in the Youtube video of 180314 (https://www.youtube.com/watch?v=CL2mVBR9cB8&t=9s). That is the one I am really waiting for.
Any news about that?

Thank you, wcb123!

I restore my acronis backup with 9.5.30 … and everything is fine now … i dont know what is the problem with 9.5.40 recording issue … i have a lot of friends without that problem … I have that problem, and some guys here … i am happy if you dont have any problems with new update … maybe, its a lucky … you never know

I went straight to 9.5.3 and fx chains have never worked. Did fx chains work in the 9.5 base install? Considering rolling back to that.

Deselection of MultiOut VSTs Channels is broken. Renders CC121 unsable.
https://www.steinberg.net/forums/viewtopic.php?f=253&t=145909



Shift-Alt-click is a feature that will place the the cursor wherever you click, so could it be that you’re unintentionally doing this?

Whenever you move the cursor either with a shift-alt-click or by dragging it, I think we all expect to see it all the time and visualize the events around it. Specially if you are planning to press play afterwards! If it doesn’t scroll automatically it means that you have to shift-alt-click, scroll and shift-alt-click again which is annoying to say the least!

Same issue for me.

I’ve checked 9.5.3 at Win 8.1 FX and Stripe presets work fine.

Drop midi to sampler track - broken.

After upgrading to version 9.5,40, I encountered a problem playing the audio in my browser, I can not listen
audio in the browser with synchronization enabled, fix this problem immediately!




Windows 10 Pro
Intel® Core™ i7-5820K CPU @ 3.30GHz
NVIDIA GeForce GTX 970\ 4,0 GB\ 2560 x 1080
RAM 15,9 GB

Me too


For me it forks fine

FX chains weren’t loading for me since upgrade from 8.5 to 9.5.3. I did a complete fresh install. Got rid of all traces of Steinberg before install as my mediabay became buggy over the years of updates.

I’m definitely not the only one.

https://www.steinberg.net/forums/viewtopic.php?f=253&t=139265

Ive noticed a major problem in the media bay when selecting samples. the preview never works and when it does it plays the same loop no matter which loop/sample i switch too. Another thing it was doing was giving me huge volume peaks that would randomly clip on the master out. might want to look into/fix this problem.

Acustica-Audio Nebula4 VST3 does not show up at all (not even on the list in the Plugin Manager) in C9.5.40 but was working fine in C9.5.30. A-A N4 VST2 version works as expected though.
A bit of a bummer really as I would like to keep as many of my plugins as possible in VST3 format. Other than this issue, 9.5.40 seems ok…so far.

Hi,

I was working with MediaBay yesterday and I cannot confirm this. Or I do something wrong. Could you please write step-by-step repro?