Cubase 9.5.40 update available

The laggy GUI remains…
Also, the freezes on closing big projects are still there

Yes, I can confirm this.

Any chance of some help here, since updating to 9.40 pro I don’t seem to be able to record audio the UR242 and Cubase do not communicate with each other.

UR44 works ok after update, but when Cubase starts i can hear cruckle noise. after 1-2 min everything start be ok


Running High Sierra and 9.5.40. Like my pal Jono, I get an instant crash to the desktop if I press record on an audio track. What I’ve been able to suss out about it:

–If I add a stereo audio track, assign a mono input to it, arm the track, and hit record in the transport, BAM! instant crash to the desktop. (Note: If I made that mistake in the past, I would just end up with a “one-sided” stereo recording.) However, if I add a stereo track and assign a stereo source and attempt to record to it, everything is fine.

–The crash happens ONLY when I have added a “mismatched” (i.e., stereo output / mono input) track to the project first and THEN I try to record to it. If instead I add a “properly matched” audio track first, then add a “mismatched” track subsequent to that, recording to the either track will not cause a crash.

–Lastly, if I have successfully recorded to a mismatched track (as described in bullet 2), then this behavior goes away completely for the rest of the current session. I can create a new song and record to whatever audio tracks I choose (“mismatched” or “matched”) in whatever order without a crash. However, if I restart Cubase, the behavior returns (until I am able to successfully record to a mismatched track as noted in this bullet).

I’ve attached my crash logs. (BTW Martin I am not familiar with “macOS Utility Console > User Reports.” I pulled these from User>Library>Logs>DiagnosticReports) (145 KB)

Shift-Alt-click is a feature that will place the the cursor wherever you click, so could it be that you’re unintentionally doing this?

Loading FX Chain worked once and now not working :open_mouth:

+1 to that.

Extremely disappointing ‘update’. I don’t need to diagnose issues each and every time an update is offered - I just want to make music!!


Here is my crash dump file
Cubase 64bit 2018.10.18 (272 KB)

Update installed & working well. Can’t confirm the record > crash thing mentioned above. Haven’t done much tricky actions since the update, so far I haven’t recognized a difference apart from new file format options.

why always after updating ,some things are fixed and some damage that always worked…
what they do and who works for them as developers. Steinberg …What is this?? whether you have answers or you do not care?

Mine FX Chain works but Stripe Presets - nothing’s happening.

What do you mean FX Chain works ? Are you experiencing same as in the video i posted or can you load fx presets? I did a clean install of 9.5 after upgrading from 8.5 6 weeks ago. It’s never worked since the upgrade. In total limbo waiting for this fix.


It’s just one thing after another :blush: :blush: :blush:

Oh dear!!! I think i’ll sit this one out for a while.

I mean I can load FX presets, but Stripe presets not.

I had to dowgrade back to 9.5.30. Im getting crackles during playback with my ur22 mkII and channel strip presets aren loading.

This ones (9.5.40) a lemon and it took since may to get it :angry: (9.5.30 has sticky pan handles but still better than crackling)

Something really has to be done with QA and beta testing because this is ridiculous. :open_mouth:

this is worst update ever !!! do not update !