Cubase 9.5.41 update available

Many of us have made suggestions like these, but Steinberg remains a “move fast and break things” kind of a company. Users must pick up the broken pieces. It’s been this way for years and is not likely to change anytime soon.

Pleased to have a working update after .30 and .40. Issue with multiple DOP processes on affecting part of the file seems to be resolved with .41, and testing different bypasses working smoothly, despite not being listed in the fixes.

The only outstanding issue is the finicky nature of sending to RX6. Sometimes it stays stuck on ‘Capturing audio…’ and the Repair buttons don’t activate.

Unbypass still actually means 'throw away all my RX work and send it back to RX to start over again. Before DOP the RX Connect exchange worked flawlessly. Undo/redo in Cubase was a better option than an unworkable bypass. Wish the old process menu was still an option.

Other than that it’s great. So thanks for the .41 hotfix.

Thanks a lot for the update coming soon and working well!

It is possible to have parallel installs with a workaround. Just copy the the cubase folder in program files before the update. Call it cubase 9.30 or whatever version it is. It will work from that folder. You can even place the folders on other drives if you want to. If you don’t like the 9.41 just delete it and rename your backup folder back to what it was. It is an at your own risk method and there might come a point it fails, but it worked here with an older version.

so I can’t open a project in 9.5.21 if I saved it with 9.5.41? (see pic)

I had some asio-freezes, so I removed the 9.5.41 update from windows programs&features. I don’t remember having this problem with previous verisons, I thought the cpr files are backwards compatible.

I work in 5.1 and here are few issues:

  • Channel Settings/inser Routing tab: no scroll and the Routing for inserts 8 and up are unreachable
  • Mixconvert (5.1 to 2) when used in send or channel out the interface appears as very older version of the plugin (looks like a old Nuendo I think)

  • channel VST MultiPanner is different (I think it is also from Nuendo)

On my older version 9.5.3 everything is fine.
I tried replacing in 9.5.41 the surroundpanner.vst3 and Mixconvert.dll from 9.5.3 but nothing changed.
Can someone tel me which files/dll I have to replace so I can get back the regular VST MultiPanner and Mixconvert?

Thanks! :smiley:

Please fix the Midi Chorder gui display bug. Was hoping these recent updates would address it but they didn’t.

i keep getting this error on install… please see attachment.

my programdata folder in registered on D: drive if it helps

help please…

win10 pro, intel i7 8700k, 32gig ram, rme hdspe aio audio card. samsung pcie m2 256gig evo system drive.
most cubase data where possible is installed on a seperate D: drive.

to mashipx
Create empty text file and change his name and expansion to OpenInCubase95_64.aepp and put this on C:\ProgramData\Steinberg\Audio Export Post Process Scripts

Original code this file:

<?xml version="1.0" encoding="UTF-8"?>
		<Path>C:\Program Files\Steinberg\Cubase 9.5\Cubase9.5.exe</Path>

Export progress bar (not moving) fixed?

I see Cubase 10 will be ‘Available Soon’. Will this be the last update for 9?

No, they use to release the last update well after the next major version has been released.
9.0.40 was released February-18, 8.5.30 was released March-17 (it’s in the version history pdf’s) (3 months after next major version).
You should expect a 9.5.50 in Q1 2019 (following earlier release pattern).


Mediabay sync is still broken for me. I thought it was fixed but upon installing v10 I noticed it was off there. I then tried loading up 9.5.41 and it’s off there too.

As before if I drag the ‘off’ loop into the project from then on the Mediabay syncs properly for that loop and any others.

Is anyone here getting consistent tight sync in the Mediabay when playing loops to the tempo of the project?

Please fix the download link for Cubase Pro 9.5.41 Update (Win 64). Mac link works, but Windows won’t even start to download.

Working fine here, downloaded 9.5.41 update completely with no problem (Windows).

I deactivated F-Secure Internet Security and managed to download the update. Just wondering why it didn’t block the Mac update, only that Windows one? :confused:

Sampler is BROKEN, doesn’t work at all when you drag and drop audio from anywhere!

If so, this is a rudeness for the users who still on 9.5 and want to keep on it for a while … ¿why the silence Steinberg?